summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-12-03 17:07:29 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-12-03 17:12:44 +0100
commit6779f681555ab5bf24b2667743e60d3bdf0d5b62 (patch)
tree4f911ee0028db95d7082b75e07a8d58d3d4cb30d /dev-ros/tf2_sensor_msgs
parentdev-ros/tf2_ros: Bump to 0.6.5. (diff)
downloadgentoo-6779f681555ab5bf24b2667743e60d3bdf0d5b62.tar.gz
gentoo-6779f681555ab5bf24b2667743e60d3bdf0d5b62.tar.bz2
gentoo-6779f681555ab5bf24b2667743e60d3bdf0d5b62.zip
dev-ros/tf2_sensor_msgs: Bump to 0.6.5.
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/tf2_sensor_msgs')
-rw-r--r--dev-ros/tf2_sensor_msgs/Manifest1
-rw-r--r--dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.5.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/tf2_sensor_msgs/Manifest b/dev-ros/tf2_sensor_msgs/Manifest
index 0bec2cc3c099..0907da9c37c5 100644
--- a/dev-ros/tf2_sensor_msgs/Manifest
+++ b/dev-ros/tf2_sensor_msgs/Manifest
@@ -1 +1,2 @@
DIST geometry2-0.6.3.tar.gz 167590 BLAKE2B 96ef84a40a8d75bbd3303774163b41d29086085cc175010731584ebfb71da87fa5264caf24c8b5b6b4450b9befc2625c6b118b8a60d032c78ce315554af74370 SHA512 f46ae3c9240073252d910e1e4b1f412ed4f534b2b3166852330ae82f1d37dde16527e12ef8a4140b41587ec664f83d8c2271376b606c55c51cee681c4d10b75b
+DIST geometry2-0.6.5.tar.gz 169353 BLAKE2B b1e710440eb9bbc1c6e2eb8af19c2d253ee891c0477583ef2572c24b917293b2ed9c205f001b28a114ae221e176d8a51e1df987b16e29e8bbba4ac396d5bf160 SHA512 b7cb6891a4f425d4c9ee0c65285bbb516e2c5fdf652fa6209df2bbd2172d95d2300250ba96dac221a553e00a0d3527ccf8b2fa7e487ad5bb6f47f3e08f74c81b
diff --git a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.5.ebuild b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.5.ebuild
new file mode 100644
index 000000000000..48bdaf11cbeb
--- /dev/null
+++ b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Transform sensor_msgs with tf. Most notably, PointCloud2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+ dev-ros/cmake_modules"