summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 14:20:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 14:20:34 +0200
commitced5dc9d8187906c45905dda3cd43681d6f29799 (patch)
treeb03d22c7dfbe7947907473022d7d43145b0a1fe3 /dev-ros/timestamp_tools/files
parentdev-ros/driver_base: Initial import. Ebuild by me. (diff)
downloadgentoo-ced5dc9d8187906c45905dda3cd43681d6f29799.tar.gz
gentoo-ced5dc9d8187906c45905dda3cd43681d6f29799.tar.bz2
gentoo-ced5dc9d8187906c45905dda3cd43681d6f29799.zip
dev-ros/timestamp_tools: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/timestamp_tools/files')
-rw-r--r--dev-ros/timestamp_tools/files/tests.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-ros/timestamp_tools/files/tests.patch b/dev-ros/timestamp_tools/files/tests.patch
new file mode 100644
index 000000000000..c73d09a1b1ac
--- /dev/null
+++ b/dev-ros/timestamp_tools/files/tests.patch
@@ -0,0 +1,14 @@
+Index: driver_common-1.6.8/timestamp_tools/CMakeLists.txt
+===================================================================
+--- driver_common-1.6.8.orig/timestamp_tools/CMakeLists.txt
++++ driver_common-1.6.8/timestamp_tools/CMakeLists.txt
+@@ -17,5 +17,7 @@ install(DIRECTORY include/${PROJECT_NAME
+ DESTINATION ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
+ FILES_MATCHING PATTERN "*.h")
+
++if(CATKIN_ENABLE_TESTING)
+ catkin_add_gtest(test_trigger_matcher test/test_trigger_matcher.cpp)
+-target_link_libraries(test_trigger_matcher ${catkin_LIBRARIES})
+\ No newline at end of file
++target_link_libraries(test_trigger_matcher ${catkin_LIBRARIES})
++endif()