summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-05 12:33:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-05 12:53:40 +0200
commit0e479e17724690c529b2c916772932100728738b (patch)
tree37ed241cf8dbd901a24f3311694303c8e28cfd7e /dev-ros
parentdev-ros/qt_gui_py_common: bump python_qt_binding in live ebuild (diff)
downloadgentoo-0e479e17724690c529b2c916772932100728738b.tar.gz
gentoo-0e479e17724690c529b2c916772932100728738b.tar.bz2
gentoo-0e479e17724690c529b2c916772932100728738b.zip
dev-ros/python_qt_binding: bump to 0.3.0
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/python_qt_binding/Manifest1
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.3.0.ebuild21
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-9999.ebuild3
3 files changed, 23 insertions, 2 deletions
diff --git a/dev-ros/python_qt_binding/Manifest b/dev-ros/python_qt_binding/Manifest
index 25cc169a2b06..c045178af47e 100644
--- a/dev-ros/python_qt_binding/Manifest
+++ b/dev-ros/python_qt_binding/Manifest
@@ -1,2 +1,3 @@
DIST python_qt_binding-0.2.17.tar.gz 12133 SHA256 7f0b5147c7b3908a09c7e771160a27d77b9047c095aa33f110345bf483b775e6 SHA512 332d63962f40d41e236a7f85e7859f1ed78dda4f02ae388e2026b53622e2551b2a702624aabf98e3fbe5d55d24f92b9c0a127386407e20ff60a5ebfbd63ffda0 WHIRLPOOL 05ecfbfaf37c94a333a517c655347f61eae17d5fa6af503e89c5f65ca624e143f7f9c097fa3f3cdda1d90b678805c1ea1228880f7074fb122fc3ebc166de2444
DIST python_qt_binding-0.2.18.tar.gz 12168 SHA256 c38e36a8e4f8aa1d1241ee03bf1527837424bed4323dc941c21f9504956f8d8d SHA512 3bb7393e582c4e8cd5f11884b31671f73248a13141c800c902c080c370615417ccd3b7673871f6bc56e4ac078efcb991118090d8037f911d2214c94353fcf833 WHIRLPOOL 0082c6464cfca8eb817da65119ee58fcd03a0ffad347888c02a642f985b30254d0d0135c76c65112a51e066891d85cb66f3110c4743a09726a911f85e690d0f8
+DIST python_qt_binding-0.3.0.tar.gz 11872 SHA256 b623e293fba060a0822a4f0d0979672ceb6886192f7e38a5cd2c29169010ded9 SHA512 d5b5e2f3f12b5b8decebdff7834cfae4ae2d581ad851a40e31c5ffc6a15e480526d0d6c6571fd8b2cc73c6d6a5315e330fd2a15944690c6712a385341b0e1133 WHIRLPOOL 7b6ea8c36e0b15b57a409c75abf53f574e230037e661a15186531402ffb4dba6306889a5efc6ed86edb9f1935d86037444670146d066d8a225c0d98ef02451e0
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.0.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.0.ebuild
new file mode 100644
index 000000000000..b7675d83d1e4
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.3.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild b/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild
index 4b34b88adf41..b7675d83d1e4 100644
--- a/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild
+++ b/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild
@@ -16,7 +16,6 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-python/pyside[${PYTHON_USEDEP}]
- dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"