summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 16:28:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:29:26 +0200
commitcce5b57eaa43b749b5a54b340d725bf9e094d0d5 (patch)
treecfc24fab33ce6c85caf475a4ce2f1b408bac8f0f /dev-ros
parentdev-ros/joint_state_publisher_gui: bump to 1.15.0 (diff)
downloadgentoo-cce5b57eaa43b749b5a54b340d725bf9e094d0d5.tar.gz
gentoo-cce5b57eaa43b749b5a54b340d725bf9e094d0d5.tar.bz2
gentoo-cce5b57eaa43b749b5a54b340d725bf9e094d0d5.zip
dev-ros/urdf_tutorial: bump to 0.5.0
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/urdf_tutorial/Manifest1
-rw-r--r--dev-ros/urdf_tutorial/urdf_tutorial-0.5.0.ebuild25
-rw-r--r--dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild6
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-ros/urdf_tutorial/Manifest b/dev-ros/urdf_tutorial/Manifest
index 5933b5e89fde..4dc7badca534 100644
--- a/dev-ros/urdf_tutorial/Manifest
+++ b/dev-ros/urdf_tutorial/Manifest
@@ -1,2 +1,3 @@
DIST urdf_tutorial-0.3.0.tar.gz 871048 BLAKE2B 2bca4409696011c75e7b6c1ae811fe4caec3fe34b28ea80c9774b6068c64509a97452173c1e43ba92f77081419b58bf5f6987e1e9941eca8ce077c534636bad9 SHA512 1518cd2aa783e92dd7a996b9cff9df37f21f7585d59b6001bd9a42782b2a5d81e96e8d2502955283f29390c7fc4944250ff1d954ab6e511e0886f243c4aabbde
DIST urdf_tutorial-0.4.0.tar.gz 865626 BLAKE2B 42a8c3274e00393f846d4e2e9641740dad214bbcdc4f65095f96f2faac1f3709170d5719085d5927ca0c322f9b8cc57b2f8494353bec629978874870a8d37206 SHA512 256859d83fb5860df27cf8922043fb61158134c1ea06f3943fed3b8183c7384819a761d83bcb03a924a813185be07e89ca510076bfa1dfe4c2e52f561503fa88
+DIST urdf_tutorial-0.5.0.tar.gz 865623 BLAKE2B 15a8337ba15c7e94a661c72a562ab4a31ca470d5d2c995aecddea69611616a2671809e085aac2857d9d2a298d92f1b5d52c11859d39c41508d7927b3d18e9607 SHA512 70390e767d7b1ace1e52d5e78b0b6775800fdc5e12d52e56603505276a9da14204bb58d680e1d9748530d0821e082c772c948947554bf48c1a9cba814495e8ed
diff --git a/dev-ros/urdf_tutorial/urdf_tutorial-0.5.0.ebuild b/dev-ros/urdf_tutorial/urdf_tutorial-0.5.0.ebuild
new file mode 100644
index 000000000000..40cde8934402
--- /dev/null
+++ b/dev-ros/urdf_tutorial/urdf_tutorial-0.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/urdf_tutorial"
+KEYWORDS="~amd64"
+
+inherit ros-catkin
+
+DESCRIPTION="URDF tutorials"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/urdf
+ dev-ros/joint_state_publisher
+ dev-ros/joint_state_publisher_gui
+ dev-ros/robot_state_publisher
+ dev-ros/rviz
+ dev-ros/xacro
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roslaunch[${PYTHON_USEDEP}] )
+"
diff --git a/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild b/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild
index 305da65fc713..40cde8934402 100644
--- a/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild
+++ b/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/urdf_tutorial"
KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -16,6 +15,7 @@ IUSE=""
RDEPEND="
dev-ros/urdf
dev-ros/joint_state_publisher
+ dev-ros/joint_state_publisher_gui
dev-ros/robot_state_publisher
dev-ros/rviz
dev-ros/xacro