summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-31 06:17:45 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-31 06:17:45 +0200
commitf59b9301817b3c9a69f2bcf2e9c6004997f84ac0 (patch)
tree2ff360ce929a5bd3c5aa3b5270162241a5be7629 /dev-ruby/capistrano/capistrano-3.11.0.ebuild
parentdev-ruby/airbrussh: add ruby25 (diff)
downloadgentoo-f59b9301817b3c9a69f2bcf2e9c6004997f84ac0.tar.gz
gentoo-f59b9301817b3c9a69f2bcf2e9c6004997f84ac0.tar.bz2
gentoo-f59b9301817b3c9a69f2bcf2e9c6004997f84ac0.zip
dev-ruby/capistrano: add 3.11.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/capistrano/capistrano-3.11.0.ebuild')
-rw-r--r--dev-ruby/capistrano/capistrano-3.11.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/capistrano/capistrano-3.11.0.ebuild b/dev-ruby/capistrano/capistrano-3.11.0.ebuild
new file mode 100644
index 000000000000..9e9844d807ec
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-3.11.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="https://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/airbrussh-1.0.0
+ >=dev-ruby/sshkit-1.9:0
+ >=dev-ruby/rake-10.0.0
+ dev-ruby/i18n:*
+ !!<dev-ruby/capistrano-2.15.5-r2"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ # Avoid specs that depend on capistrano already being installed
+ rm -f spec/lib/capistrano/doctor/gems_doctor_spec.rb || die
+
+ # Avoid specs that require a TTY
+ sed -i -e '/asking for a variable/,/^ end/ s:^:#:' spec/integration/dsl_spec.rb || die
+ rm -f spec/lib/capistrano/configuration/question_spec.rb || die
+}