summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-05-09 07:02:00 +0200
committerHans de Graaff <graaff@gentoo.org>2017-05-09 07:02:00 +0200
commita0ad5be1fab7a625b2c7c803b677a4ff8e11893a (patch)
tree7949469f3314f164f8ed42c844dc319481339e5c /dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild
parentdev-embedded/u-boot-tools: version bump to 2017.05 (diff)
downloadgentoo-a0ad5be1fab7a625b2c7c803b677a4ff8e11893a.tar.gz
gentoo-a0ad5be1fab7a625b2c7c803b677a4ff8e11893a.tar.bz2
gentoo-a0ad5be1fab7a625b2c7c803b677a4ff8e11893a.zip
dev-ruby/debug_inspector: add 0.0.3
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild')
-rw-r--r--dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild b/dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild
new file mode 100644
index 000000000000..f0281c17e624
--- /dev/null
+++ b/dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby wrapper for the MRI 2.0 debug_inspector API"
+HOMEPAGE="https://github.com/banister/debug_inspector"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/${PN}.so lib/ || die
+}