summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild')
-rw-r--r--dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild b/dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild
new file mode 100644
index 000000000000..f0281c17e624
--- /dev/null
+++ b/dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby wrapper for the MRI 2.0 debug_inspector API"
+HOMEPAGE="https://github.com/banister/debug_inspector"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/${PN}.so lib/ || die
+}