summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-12-01 07:44:59 +0100
committerHans de Graaff <graaff@gentoo.org>2015-12-02 07:16:49 +0100
commitef9b0e452462f476611ac986f6ed262f75e42301 (patch)
treec1d20667432f35b5efcf230572b4aa57feb34c16 /dev-ruby/jmespath/jmespath-1.1.3.ebuild
parentdev-ruby/aws-sdk: cleanup (diff)
downloadgentoo-ef9b0e452462f476611ac986f6ed262f75e42301.tar.gz
gentoo-ef9b0e452462f476611ac986f6ed262f75e42301.tar.bz2
gentoo-ef9b0e452462f476611ac986f6ed262f75e42301.zip
dev-ruby/jmespath: initial import
New dependency for dev-ruby/aws-sdk Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/jmespath/jmespath-1.1.3.ebuild')
-rw-r--r--dev-ruby/jmespath/jmespath-1.1.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/jmespath-1.1.3.ebuild b/dev-ruby/jmespath/jmespath-1.1.3.ebuild
new file mode 100644
index 000000000000..be1a31aa70da
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,spec_helper}.rb || die
+}