summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-12-16 07:35:36 +0100
committerHans de Graaff <graaff@gentoo.org>2018-12-16 07:35:36 +0100
commit9d8b61964edede957a780f6614e16581468b56da (patch)
tree745216456655536aa2c63343d750b6760d2f483d /dev-ruby/rb-inotify/rb-inotify-0.10.0.ebuild
parentwww-servers/civetweb: fix mixed use of tabs and spaces (diff)
downloadgentoo-9d8b61964edede957a780f6614e16581468b56da.tar.gz
gentoo-9d8b61964edede957a780f6614e16581468b56da.tar.bz2
gentoo-9d8b61964edede957a780f6614e16581468b56da.zip
dev-ruby/rb-inotify: add 0.10.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/rb-inotify/rb-inotify-0.10.0.ebuild')
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.10.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.10.0.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.10.0.ebuild
new file mode 100644
index 000000000000..05e307428f60
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on jeweler.
+ sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+
+ sed -i -e '/bundler/ s:^:#:' -e '1irequire "pathname"' spec/spec_helper.rb || die
+}