summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rkelly-remix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rkelly-remix')
-rw-r--r--dev-ruby/rkelly-remix/Manifest2
-rw-r--r--dev-ruby/rkelly-remix/metadata.xml14
-rw-r--r--dev-ruby/rkelly-remix/rkelly-remix-0.0.6.ebuild25
-rw-r--r--dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild25
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-ruby/rkelly-remix/Manifest b/dev-ruby/rkelly-remix/Manifest
new file mode 100644
index 000000000000..f68ed1dfdd57
--- /dev/null
+++ b/dev-ruby/rkelly-remix/Manifest
@@ -0,0 +1,2 @@
+DIST rkelly-remix-0.0.6.gem 69120 SHA256 3fdcaee584b2d1050cf207b4fbddad5637d3502d1ceb23f733a95bb48bb61ac6 SHA512 11c30cb4ba0edcb0470ceeeacadeb6cc02f4408a8fc4bcbdb47fcb1c46665c0ac800e16cadf172d64483ba13e2ae2a8c032b138391e3b6495f3c199a0967fa93 WHIRLPOOL d6bf1e8c0260ba48b57f4232d4b85330e3b306442ef742643ed0b302108744677a00a94a8eeb42e3196f1faf4a9fc5c6095a18b69c002a3eb029954d0eb2ef47
+DIST rkelly-remix-0.0.7.gem 69632 SHA256 72f870b39931daa49ac1c78ceadeeeaebf0eee7395597afc28c99d6e1395f0bc SHA512 5450b4b52b912b6626fcac3e3428dd2b4520dcb62b402e36579c9b34e8a027853e53a0860f33b4efc995517d70a3fab4f75f28ce7ab0b2b0c9e09e72ddd7cd54 WHIRLPOOL 9ab7d4f8f8fa58855b1f4ee754ef753407f1e966f7bada8a8304b4e049ffdfe87a9adb92e89321468792c6ae0a35a41987bcd1ce039c86220792774b44c558f0
diff --git a/dev-ruby/rkelly-remix/metadata.xml b/dev-ruby/rkelly-remix/metadata.xml
new file mode 100644
index 000000000000..4d2c785cf3f6
--- /dev/null
+++ b/dev-ruby/rkelly-remix/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">nene/rkelly-remix</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rkelly-remix/rkelly-remix-0.0.6.ebuild b/dev-ruby/rkelly-remix/rkelly-remix-0.0.6.ebuild
new file mode 100644
index 000000000000..9d424197b0c8
--- /dev/null
+++ b/dev-ruby/rkelly-remix/rkelly-remix-0.0.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RKelly Remix is a fork of the RKelly JavaScript parser"
+HOMEPAGE="https://github.com/nene/rkelly-remix"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="doc"
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe dev-ruby/rdoc )"
+
+each_ruby_test() {
+ ${RUBY} -S testrb -Ilib:. test/test_*.rb test/*/test_*.rb || die
+}
diff --git a/dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild b/dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild
new file mode 100644
index 000000000000..dd61f8b84ef1
--- /dev/null
+++ b/dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RKelly Remix is a fork of the RKelly JavaScript parser"
+HOMEPAGE="https://github.com/nene/rkelly-remix"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="doc"
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe dev-ruby/rdoc )"
+
+each_ruby_test() {
+ ${RUBY} -S testrb -Ilib:. test/test_*.rb test/*/test_*.rb || die
+}