summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-24 15:16:03 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-24 15:16:07 -0700
commit97a90dff776eb9b4f723fd47f44154626df8d100 (patch)
treeb6d58f29f43e0e66c99889d8d4bf56373d08e23f /dev-util/ccls/ccls-0.20190823.6.ebuild
parentapp-forensics/honggfuzz: bump up to 2.2 (diff)
downloadgentoo-97a90dff776eb9b4f723fd47f44154626df8d100.tar.gz
gentoo-97a90dff776eb9b4f723fd47f44154626df8d100.tar.bz2
gentoo-97a90dff776eb9b4f723fd47f44154626df8d100.zip
dev-util/ccls: Version bump to 0.20190823.6
Closes: https://bugs.gentoo.org/712314 Closes: https://bugs.gentoo.org/714764 Closes: https://bugs.gentoo.org/719034 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/ccls/ccls-0.20190823.6.ebuild')
-rw-r--r--dev-util/ccls/ccls-0.20190823.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/ccls/ccls-0.20190823.6.ebuild b/dev-util/ccls/ccls-0.20190823.6.ebuild
new file mode 100644
index 000000000000..d959663fa6f0
--- /dev/null
+++ b/dev-util/ccls/ccls-0.20190823.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit cmake ${GIT_ECLASS}
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-libs/rapidjson
+ sys-devel/clang:=
+ sys-devel/llvm:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_RAPIDJSON=ON
+ )
+ cmake_src_configure
+}