summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-07-19 11:46:08 -0400
committerCraig Andrews <candrews@gentoo.org>2019-07-19 11:47:10 -0400
commite4ba8f5a8fa699b615f406bd7f4b4f5ef7a736a2 (patch)
tree85d42f0df1fe67602cd4cc0c8050691ccf7c1b31 /dev-util/conf2struct/conf2struct-9999.ebuild
parentdev-util/conf2struct: Disable parallel make (diff)
downloadgentoo-e4ba8f5a8fa699b615f406bd7f4b4f5ef7a736a2.tar.gz
gentoo-e4ba8f5a8fa699b615f406bd7f4b4f5ef7a736a2.tar.bz2
gentoo-e4ba8f5a8fa699b615f406bd7f4b4f5ef7a736a2.zip
dev-util/conf2struct: Respect CFLAGS and CC
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util/conf2struct/conf2struct-9999.ebuild')
-rw-r--r--dev-util/conf2struct/conf2struct-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-util/conf2struct/conf2struct-9999.ebuild b/dev-util/conf2struct/conf2struct-9999.ebuild
index f20edc27e4db..b853d93f1b86 100644
--- a/dev-util/conf2struct/conf2struct-9999.ebuild
+++ b/dev-util/conf2struct/conf2struct-9999.ebuild
@@ -23,6 +23,10 @@ RDEPEND="dev-libs/libconfig
dev-perl/Conf-Libconfig"
DEPEND="${RDEPEND}"
+src_compile(){
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
src_install(){
emake DESTDIR="${D}" prefix="${EPREFIX%/}/usr" install
}