summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/ctags/ctags-5.8-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/ctags/ctags-5.8-r1.ebuild')
-rw-r--r--dev-util/ctags/ctags-5.8-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/ctags/ctags-5.8-r1.ebuild b/dev-util/ctags/ctags-5.8-r1.ebuild
new file mode 100644
index 000000000000..c2fb30b158ba
--- /dev/null
+++ b/dev-util/ctags/ctags-5.8-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
+HOMEPAGE="http://ctags.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ ada? ( mirror://sourceforge/gnuada/ctags-ada-mode-4.3.11.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="ada"
+
+RDEPEND="app-eselect/eselect-ctags"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-5.6-ebuilds.patch"
+ # Upstream fix for python variables starting with def
+ epatch "${FILESDIR}/${P}-python-vars-starting-with-def.patch"
+
+ # Bug #273697
+ epatch "${FILESDIR}/${P}-f95-pointers.patch"
+
+ # enabling Ada support
+ if use ada ; then
+ cp "${WORKDIR}/${PN}-ada-mode-4.3.11/ada.c" "${S}" || die
+ epatch "${FILESDIR}/${P}-ada.patch"
+ fi
+}
+
+src_configure() {
+ econf \
+ --with-posix-regex \
+ --without-readlib \
+ --disable-etags \
+ --enable-tmpdir=/tmp
+}
+
+src_install() {
+ emake prefix="${D}"/usr mandir="${D}"/usr/share/man install
+
+ # namepace collision with X/Emacs-provided /usr/bin/ctags -- we
+ # rename ctags to exuberant-ctags (Mandrake does this also).
+ mv "${D}"/usr/bin/{ctags,exuberant-ctags} || die
+ mv "${D}"/usr/share/man/man1/{ctags,exuberant-ctags}.1 || die
+
+ dodoc FAQ NEWS README
+ dohtml EXTENDING.html ctags.html
+}
+
+pkg_postinst() {
+ eselect ctags update
+ elog "You can set the version to be started by /usr/bin/ctags through"
+ elog "the ctags eselect module. \"man ctags.eselect\" for details."
+}
+
+pkg_postrm() {
+ eselect ctags update
+}