summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-06-17 13:06:10 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-06-17 13:06:43 -0500
commitcd304aad8b8f46ee86be576614a862ac0b33d5b3 (patch)
tree335c8d51b27dc399e20301db250c5ae3bbcfd40a /dev-util/diff-cover/diff-cover-6.5.0.ebuild
parentsci-libs/tensorflow: restrict flatbuffers dep (diff)
downloadgentoo-cd304aad8b8f46ee86be576614a862ac0b33d5b3.tar.gz
gentoo-cd304aad8b8f46ee86be576614a862ac0b33d5b3.tar.bz2
gentoo-cd304aad8b8f46ee86be576614a862ac0b33d5b3.zip
dev-util/diff-cover: add 6.5.0
Closes: https://bugs.gentoo.org/845933 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/diff-cover/diff-cover-6.5.0.ebuild')
-rw-r--r--dev-util/diff-cover/diff-cover-6.5.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/diff-cover/diff-cover-6.5.0.ebuild b/dev-util/diff-cover/diff-cover-6.5.0.ebuild
new file mode 100644
index 000000000000..9a3fea81c28c
--- /dev/null
+++ b/dev-util/diff-cover/diff-cover-6.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{7..11} )
+inherit distutils-r1
+
+DESCRIPTION="Find diff lines that do not have test coverage"
+HOMEPAGE="https://github.com/Bachmann1234/diff-cover"
+SRC_URI="https://github.com/Bachmann1234/diff-cover/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/diff-cover/diff_cover}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-python/chardet-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7.1[${PYTHON_USEDEP}]
+ dev-python/jinja2_pluralize[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest