summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/indent/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/indent/files')
-rw-r--r--dev-util/indent/files/2.2.11-segfault.patch16
-rw-r--r--dev-util/indent/files/2.2.11-texi2html-5.patch40
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/indent/files/2.2.11-segfault.patch b/dev-util/indent/files/2.2.11-segfault.patch
new file mode 100644
index 000000000000..e91922480951
--- /dev/null
+++ b/dev-util/indent/files/2.2.11-segfault.patch
@@ -0,0 +1,16 @@
+--- a/man/texinfo2man.c
++++ b/man/texinfo2man.c
+@@ -287,6 +287,13 @@
+ char buf[1024];
+ int line_no = 0;
+
++ if (argc != 3)
++ {
++ fprintf(stderr, "Usage: %s <man template> <info file>\n", argv[0]);
++ fprintf(stderr, " The man page will be written to stdout.\n");
++ return -1;
++ }
++
+ texinfoname = argv[2];
+
+ in = fopen (argv[2], "r");
diff --git a/dev-util/indent/files/2.2.11-texi2html-5.patch b/dev-util/indent/files/2.2.11-texi2html-5.patch
new file mode 100644
index 000000000000..5bad3da2867b
--- /dev/null
+++ b/dev-util/indent/files/2.2.11-texi2html-5.patch
@@ -0,0 +1,40 @@
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -34,14 +34,14 @@
+ html-split: @PACKAGE@_toc.html
+
+ @PACKAGE@.html: version.texi $(@PACKAGE@_TEXINFOS)
+- $(TEXI2HTML) -expandinfo -number -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
++ $(TEXI2HTML) -expandinfo -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
+
+ @PACKAGE@_toc.html: version.texi $(@PACKAGE@_TEXINFOS)
+ case "$(TEXI2HTML)" in \
+ *"/missing texi2html") \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
++ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
+ *) $(RM) @PACKAGE@_*.html ; \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
++ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
+ esac
+
+ install-html-monolithic: @PACKAGE@.html
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -663,14 +663,14 @@
+ html-split: @PACKAGE@_toc.html
+
+ @PACKAGE@.html: version.texi $(@PACKAGE@_TEXINFOS)
+- $(TEXI2HTML) -expandinfo -number -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
++ $(TEXI2HTML) -expandinfo -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
+
+ @PACKAGE@_toc.html: version.texi $(@PACKAGE@_TEXINFOS)
+ case "$(TEXI2HTML)" in \
+ *"/missing texi2html") \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
++ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
+ *) $(RM) @PACKAGE@_*.html ; \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
++ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
+ esac
+
+ install-html-monolithic: @PACKAGE@.html