summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/indent/files')
-rw-r--r--dev-util/indent/files/2.2.11-segfault.patch16
-rw-r--r--dev-util/indent/files/2.2.11-texi2html-5.patch40
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/indent/files/2.2.11-segfault.patch b/dev-util/indent/files/2.2.11-segfault.patch
new file mode 100644
index 000000000000..e91922480951
--- /dev/null
+++ b/dev-util/indent/files/2.2.11-segfault.patch
@@ -0,0 +1,16 @@
+--- a/man/texinfo2man.c
++++ b/man/texinfo2man.c
+@@ -287,6 +287,13 @@
+ char buf[1024];
+ int line_no = 0;
+
++ if (argc != 3)
++ {
++ fprintf(stderr, "Usage: %s <man template> <info file>\n", argv[0]);
++ fprintf(stderr, " The man page will be written to stdout.\n");
++ return -1;
++ }
++
+ texinfoname = argv[2];
+
+ in = fopen (argv[2], "r");
diff --git a/dev-util/indent/files/2.2.11-texi2html-5.patch b/dev-util/indent/files/2.2.11-texi2html-5.patch
new file mode 100644
index 000000000000..5bad3da2867b
--- /dev/null
+++ b/dev-util/indent/files/2.2.11-texi2html-5.patch
@@ -0,0 +1,40 @@
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -34,14 +34,14 @@
+ html-split: @PACKAGE@_toc.html
+
+ @PACKAGE@.html: version.texi $(@PACKAGE@_TEXINFOS)
+- $(TEXI2HTML) -expandinfo -number -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
++ $(TEXI2HTML) -expandinfo -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
+
+ @PACKAGE@_toc.html: version.texi $(@PACKAGE@_TEXINFOS)
+ case "$(TEXI2HTML)" in \
+ *"/missing texi2html") \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
++ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
+ *) $(RM) @PACKAGE@_*.html ; \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
++ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
+ esac
+
+ install-html-monolithic: @PACKAGE@.html
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -663,14 +663,14 @@
+ html-split: @PACKAGE@_toc.html
+
+ @PACKAGE@.html: version.texi $(@PACKAGE@_TEXINFOS)
+- $(TEXI2HTML) -expandinfo -number -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
++ $(TEXI2HTML) -expandinfo -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
+
+ @PACKAGE@_toc.html: version.texi $(@PACKAGE@_TEXINFOS)
+ case "$(TEXI2HTML)" in \
+ *"/missing texi2html") \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
++ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
+ *) $(RM) @PACKAGE@_*.html ; \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
++ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
+ esac
+
+ install-html-monolithic: @PACKAGE@.html