summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-05-19 07:47:26 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-05-25 14:12:35 +0300
commitac2512786881302c1e98643515c2c7094cb3cec8 (patch)
treecad2575394c30794f49b4c403dc3ff14d7b15a72 /dev-util/rebar-bin/rebar-bin-3.16.1.ebuild
parentdev-util/github-cli: Bump version to 1.10.3 (diff)
downloadgentoo-ac2512786881302c1e98643515c2c7094cb3cec8.tar.gz
gentoo-ac2512786881302c1e98643515c2c7094cb3cec8.tar.bz2
gentoo-ac2512786881302c1e98643515c2c7094cb3cec8.zip
dev-util/rebar-bin: Bump to 3.16.1
Bug: https://bugs.gentoo.org/791862 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/rebar-bin/rebar-bin-3.16.1.ebuild')
-rw-r--r--dev-util/rebar-bin/rebar-bin-3.16.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/rebar-bin/rebar-bin-3.16.1.ebuild b/dev-util/rebar-bin/rebar-bin-3.16.1.ebuild
new file mode 100644
index 000000000000..83bb5eb671c1
--- /dev/null
+++ b/dev-util/rebar-bin/rebar-bin-3.16.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${P#-bin}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://rebar3.org https://github.com/erlang/rebar3"
+
+SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3 -> ${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/erlang"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/usr/bin/rebar3"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${P}" "${S}/rebar3" || die
+}
+
+src_install() {
+ dobin rebar3
+}