summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-12-27 17:06:28 -0800
committerSam James <sam@gentoo.org>2023-01-15 14:16:10 +0000
commit46ddc2d43b3c5adbbb33d1a02222ba0e9c9c1f0c (patch)
tree0fb14895a4f30f16827f579d7b28abf692223ac0 /dev-util/rgbds/rgbds-9999.ebuild
parentwww-client/chromium-bin: add ppc64le without keywords (diff)
downloadgentoo-46ddc2d43b3c5adbbb33d1a02222ba0e9c9c1f0c.tar.gz
gentoo-46ddc2d43b3c5adbbb33d1a02222ba0e9c9c1f0c.tar.bz2
gentoo-46ddc2d43b3c5adbbb33d1a02222ba0e9c9c1f0c.zip
dev-util/rgbds: New package, v0.6.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/rgbds/rgbds-9999.ebuild')
-rw-r--r--dev-util/rgbds/rgbds-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/rgbds/rgbds-9999.ebuild b/dev-util/rgbds/rgbds-9999.ebuild
new file mode 100644
index 000000000000..9245f4deb4f2
--- /dev/null
+++ b/dev-util/rgbds/rgbds-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Rednex Game Boy Development System"
+HOMEPAGE="https://rgbds.gbdev.io/"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gbdev/${PN}.git"
+else
+ SRC_URI="https://github.com/gbdev/${PN}/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ZLIB"
+SLOT="0"
+
+DEPEND="media-libs/libpng"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ append-flags -DNDEBUG
+
+ emake Q= \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr Q= STRIP= install
+ dodoc README.rst
+}