summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-11-08 22:52:12 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-11-08 22:52:12 +0000
commita1c68dec259a290272d5f147dee141681a358c48 (patch)
tree5e4facf1e4e99f4b21c0452bf9071ea58898c9de /dev-util
parentwww-apps/xpra-html5: Bump to 6.1, drop old 6.0 (diff)
downloadgentoo-a1c68dec259a290272d5f147dee141681a358c48.tar.gz
gentoo-a1c68dec259a290272d5f147dee141681a358c48.tar.bz2
gentoo-a1c68dec259a290272d5f147dee141681a358c48.zip
dev-util/patchelf: Version bump to 0.17.0
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/patchelf/Manifest1
-rw-r--r--dev-util/patchelf/patchelf-0.17.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/patchelf/Manifest b/dev-util/patchelf/Manifest
index 62d714d2ceea..70bafe695f3c 100644
--- a/dev-util/patchelf/Manifest
+++ b/dev-util/patchelf/Manifest
@@ -1,2 +1,3 @@
DIST patchelf-0.15.0.tar.gz 125803 BLAKE2B 08fc2cffd7d9e835c01c828c16762fb0b3c3e422990f2d0028a65a3e0ec849d01bdef699b6f68afa6bf307e34f5e76121fc94460793c95c055552e1d8a68d772 SHA512 3b2d3d6458be5b2d43cd2878dfb1a185a95cc13cd4c94abd0ee79979afb36f46e347acc292b8d9c2954a342b7291774e6a1b63930e9f90a1cf4179ec075ab046
DIST patchelf-0.16.1.tar.gz 132450 BLAKE2B 047fe9900eff3a4fef19550b49ea3c53dc8fc77c1d110888af39362dce745c3568e493f91d96cd35d73291da8e0cf4f10121162f4e8a32d43a3c014716477a4c SHA512 62475b942ff07c2eb225760d69eab99af4e9aa14ca51aeb3b7d53a6a1943b02acffc1b2059d985a921f5af7bbaf40a096b8cdf592979260e1e2602db02e7f247
+DIST patchelf-0.17.0.tar.gz 143684 BLAKE2B ef32baae1d1e07c77442878977693849e2dd3d5c1c1b8d53eb54ee7b1b78eb77ebcf87cbd7caa683f0043e6d7b90ca2593968e9c95b0902e45c4634823be196b SHA512 0db2294cc16a919a84a1bb71194b3ed7a87bb669f684e4cc0943b33899d69690097c59d5c9f8e631bc1b4136db7f10f7cb0fbb1c96912aee567a0fd7dc9c9588
diff --git a/dev-util/patchelf/patchelf-0.17.0.ebuild b/dev-util/patchelf/patchelf-0.17.0.ebuild
new file mode 100644
index 000000000000..45b8be95445b
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.17.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="https://github.com/NixOS/patchelf"
+SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~riscv-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+
+ eautoreconf
+}