summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2020-08-20 00:49:07 -0400
committerMike Frysinger <vapier@gentoo.org>2020-08-20 00:49:07 -0400
commit377d5861d13dc5da17af4aed9ba65a54a58cc1a7 (patch)
treef6df77c9bf36993ac3338ea714fb4e4d5df14d33 /dev-vcs/repo/repo-2.8.ebuild
parentdev-perl/ExtUtils-CppGuess: Bump to version 0.210.0 (diff)
downloadgentoo-377d5861d13dc5da17af4aed9ba65a54a58cc1a7.tar.gz
gentoo-377d5861d13dc5da17af4aed9ba65a54a58cc1a7.tar.bz2
gentoo-377d5861d13dc5da17af4aed9ba65a54a58cc1a7.zip
dev-vcs/repo: version bump to 2.8
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'dev-vcs/repo/repo-2.8.ebuild')
-rw-r--r--dev-vcs/repo/repo-2.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/repo/repo-2.8.ebuild b/dev-vcs/repo/repo-2.8.ebuild
new file mode 100644
index 000000000000..544acae9a81b
--- /dev/null
+++ b/dev-vcs/repo/repo-2.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The $PV tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S=${WORKDIR}
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+}