summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-01 00:00:39 +0000
committerSam James <sam@gentoo.org>2021-04-11 20:59:55 +0000
commitfe3f65790fabb6e98d0b851d3013714c7706eccc (patch)
tree1df6bcc667d1bc27a090aa9b0e3066ac8121011d /eclass
parentautotools.eclass: add explicit GNU awk dependency (diff)
downloadgentoo-fe3f65790fabb6e98d0b851d3013714c7706eccc.tar.gz
gentoo-fe3f65790fabb6e98d0b851d3013714c7706eccc.tar.bz2
gentoo-fe3f65790fabb6e98d0b851d3013714c7706eccc.zip
autotools.eclass: rename configure.in to configure.ac on new EAPIs
automake is eventually going to fail when it detects configure.in. Don't do this immediately - instead only on new EAPIs to avoid breaking existing ebuilds. Bug: https://bugs.gentoo.org/426262 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/autotools.eclass16
1 files changed, 13 insertions, 3 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index ab62584a5b79..04d94d882607 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -383,9 +383,19 @@ eautoconf() {
fi
if [[ ${WANT_AUTOCONF} != "2.1" && -e configure.in ]] ; then
- eqawarn "This package has a configure.in file which has long been deprecated. Please"
- eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
- eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
+ case ${EAPI:-0} in
+ 5|6|7)
+ eqawarn "This package has a configure.in file which has long been deprecated. Please"
+ eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
+ eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
+ ;;
+ *)
+ # Move configure file to the new location only on newer EAPIs to ensure
+ # checks are done rather than retroactively breaking ebuilds.
+ einfo "Moving configure.in to configure.ac (bug #426262)"
+ mv configure.{in,ac} || die
+ ;;
+ esac
fi
# Install config.guess and config.sub which are required by many macros