summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
Diffstat (limited to 'eclass')
-rw-r--r--eclass/autotools.eclass16
1 files changed, 13 insertions, 3 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index ab62584a5b79..04d94d882607 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -383,9 +383,19 @@ eautoconf() {
fi
if [[ ${WANT_AUTOCONF} != "2.1" && -e configure.in ]] ; then
- eqawarn "This package has a configure.in file which has long been deprecated. Please"
- eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
- eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
+ case ${EAPI:-0} in
+ 5|6|7)
+ eqawarn "This package has a configure.in file which has long been deprecated. Please"
+ eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
+ eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
+ ;;
+ *)
+ # Move configure file to the new location only on newer EAPIs to ensure
+ # checks are done rather than retroactively breaking ebuilds.
+ einfo "Moving configure.in to configure.ac (bug #426262)"
+ mv configure.{in,ac} || die
+ ;;
+ esac
fi
# Install config.guess and config.sub which are required by many macros