summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-19 18:03:58 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-20 08:40:31 -0400
commit3cc2ebf405185d94b5a3944953f8a742bc4d6540 (patch)
treed245a6382c81997c0019ecf6ef2cb2a10e165071 /games-action/barrage/barrage-1.0.5.ebuild
parentgames-action/atanks: gnome2-utils--, fix icon cache qa (diff)
downloadgentoo-3cc2ebf405185d94b5a3944953f8a742bc4d6540.tar.gz
gentoo-3cc2ebf405185d94b5a3944953f8a742bc4d6540.tar.bz2
gentoo-3cc2ebf405185d94b5a3944953f8a742bc4d6540.zip
games-action/barrage: add 1.0.5
This version adds a highscore file, and upstream's .desktop was improved (minus icon issues) so now using it. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-action/barrage/barrage-1.0.5.ebuild')
-rw-r--r--games-action/barrage/barrage-1.0.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-action/barrage/barrage-1.0.5.ebuild b/games-action/barrage/barrage-1.0.5.ebuild
new file mode 100644
index 000000000000..62254d9f380d
--- /dev/null
+++ b/games-action/barrage/barrage-1.0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop
+
+DESCRIPTION="Violent point-and-click shooting game"
+HOMEPAGE="http://lgames.sourceforge.net/Barrage/"
+SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ acct-group/gamestat
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --localstatedir="${EPREFIX}"/var/games
+}
+
+src_compile() {
+ default
+
+ # generated .desktop hardcodes icon path (and in wrong location)
+ sed -i "/^Icon=/s|=.*|=${PN}|" ${PN}.desktop || die
+}
+
+src_install() {
+ default
+
+ fowners :gamestat /{usr/bin/${PN},var/games/${PN}.hscr}
+ fperms g+s /usr/bin/${PN}
+ fperms 660 /var/games/${PN}.hscr
+
+ rm "${ED}"/usr/share/icons/${PN}48.png || die
+ newicon ${PN}48.png ${PN}.png
+}