summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 11:45:57 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:43:16 +0100
commitbce01daaee3485d1024c44be47186cbdd232f915 (patch)
tree17624618236179a41bd5b4ea17ff270f05e1e3de /games-action
parentgames-action/dxx-rebirth: fix variable references (diff)
downloadgentoo-bce01daaee3485d1024c44be47186cbdd232f915.tar.gz
gentoo-bce01daaee3485d1024c44be47186cbdd232f915.tar.bz2
gentoo-bce01daaee3485d1024c44be47186cbdd232f915.zip
games-action/dxx-rebirth: fix variable references
Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20200615.ebuild10
-rw-r--r--games-action/dxx-rebirth/dxx-rebirth-9999.ebuild8
2 files changed, 9 insertions, 9 deletions
diff --git a/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20200615.ebuild b/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20200615.ebuild
index b2446c72681e..73b3b5ec1c13 100644
--- a/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20200615.ebuild
+++ b/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20200615.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
inherit desktop eutils python-any-r1 scons-utils toolchain-funcs xdg
-if [[ "$PV" = 9999 ]]; then
+if [[ "${PV}" = 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/dxx-rebirth/dxx-rebirth"
PROPERTIES="live"
@@ -17,9 +17,9 @@ else
MY_COMMIT='0c2fcf691ffb2a586991350d67f3efd1cca2a1f3'
# dxx-rebirth-0.61.0_pre20200627.ebuild
#MY_COMMIT='aba40babb47d36a88011af01e4bc0fc00dca74ef'
- S="$WORKDIR/$PN-$MY_COMMIT"
- #SRC_URI="https://github.com/dxx-rebirth/dxx-rebirth/archive/$MY_COMMIT.tar.gz -> $PN-$PVR.tar.gz"
- SRC_URI="https://codeload.github.com/dxx-rebirth/dxx-rebirth/tar.gz/$MY_COMMIT -> $PN-$PVR.tar.gz"
+ S="${WORKDIR}/${P}N-${MY_COMMIT}"
+ #SRC_URI="https://github.com/dxx-rebirth/dxx-rebirth/archive/${MY_COMMIT}.tar.gz -> ${PN}-${PVR}.tar.gz"
+ SRC_URI="https://codeload.github.com/dxx-rebirth/dxx-rebirth/tar.gz/${MY_COMMIT} -> ${PN}-${PVR}.tar.gz"
unset MY_COMMIT
# Games under Gentoo are marked as 'testing' by convention
@@ -227,7 +227,7 @@ src_compile() {
src_install() {
# Use upstream install target to handle the various combinations of
# enabled/disabled engines and optional editor support.
- dxx_scons register_compile_target=0 register_install_target=1 DESTDIR="$D" "$D"
+ dxx_scons register_compile_target=0 register_install_target=1 DESTDIR="${D}" "${D}"
local DV
for DV in 1 2; do
if ! use d${DV}x; then
diff --git a/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild b/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
index c111e88ee3ac..425230e43c69 100644
--- a/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
+++ b/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
@@ -6,14 +6,14 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
inherit desktop eutils python-any-r1 scons-utils toolchain-funcs xdg
-if [[ "$PV" = 9999 ]]; then
+if [[ "${PV}" = 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/dxx-rebirth/dxx-rebirth"
PROPERTIES="live"
else
MY_COMMIT=''
- S="$WORKDIR/$PN-$MY_COMMIT"
- SRC_URI="https://codeload.github.com/dxx-rebirth/dxx-rebirth/tar.gz/$MY_COMMIT -> $PN-$PVR.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_COMMIT}"
+ SRC_URI="https://codeload.github.com/dxx-rebirth/dxx-rebirth/tar.gz/${MY_COMMIT} -> ${PN}-${PVR}.tar.gz"
unset MY_COMMIT
# Other architectures are reported to work, but not tested regularly by
@@ -219,7 +219,7 @@ src_compile() {
src_install() {
# Use upstream install target to handle the various combinations of
# enabled/disabled engines and optional editor support.
- dxx_scons register_compile_target=0 register_install_target=1 DESTDIR="$D" "$D"
+ dxx_scons register_compile_target=0 register_install_target=1 DESTDIR="${D}" "${D}"
local DV
for DV in 1 2; do
if ! use d${DV}x; then