summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-03 19:32:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-03 20:15:09 -0400
commit4901013b1c91d3ce3815751eb9f7a664f16f2751 (patch)
tree94981311f310fa39f5520eee0672227d688536b3 /games-arcade/excido/excido-0.1.5c-r4.ebuild
parentgames-arcade/excido: EAPI7 bump (diff)
downloadgentoo-4901013b1c91d3ce3815751eb9f7a664f16f2751.tar.gz
gentoo-4901013b1c91d3ce3815751eb9f7a664f16f2751.tar.bz2
gentoo-4901013b1c91d3ce3815751eb9f7a664f16f2751.zip
games-arcade/excido: fix direct c++, add desktop file
Plus small style perference changes. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade/excido/excido-0.1.5c-r4.ebuild')
-rw-r--r--games-arcade/excido/excido-0.1.5c-r4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/excido/excido-0.1.5c-r4.ebuild b/games-arcade/excido/excido-0.1.5c-r4.ebuild
new file mode 100644
index 000000000000..6dd286165633
--- /dev/null
+++ b/games-arcade/excido/excido-0.1.5c-r4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Fast paced action game"
+HOMEPAGE="https://icculus.org/excido/"
+SRC_URI="https://icculus.org/excido/${P}-src.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-games/physfs
+ media-libs/freealut
+ media-libs/libsdl[opengl]
+ media-libs/openal
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-freealut.patch
+ "${FILESDIR}"/${P}-build.patch
+)
+
+src_compile() {
+ tc-export CXX
+
+ emake DATADIR=/usr/share/${PN}/
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/${PN}
+ doins -r data/.
+
+ dodoc BUGS CHANGELOG HACKING README TODO \
+ data/{CREDITS,readme-jf-nebula_sky.txt} keyguide.txt
+
+ make_desktop_entry ${PN} Excido applications-games "Game;ArcadeGame"
+}