summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-28 03:12:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-28 12:42:38 -0400
commit3113c776c9a79ce989152d78bb5d17cb7b773954 (patch)
treebe56584678c7d3a81e78dda05ec7dc5ecc4cb473 /games-arcade
parentgames-arcade/pengupop: EAPI 6->8, simplify ebuild (diff)
downloadgentoo-3113c776c9a79ce989152d78bb5d17cb7b773954.tar.gz
gentoo-3113c776c9a79ce989152d78bb5d17cb7b773954.tar.bz2
gentoo-3113c776c9a79ce989152d78bb5d17cb7b773954.zip
games-arcade/vor: add 0.5.8, EAPI 6->8
This version also fixes previous gcc10/-fno-common issues. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/vor/Manifest1
-rw-r--r--games-arcade/vor/vor-0.5.8.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/games-arcade/vor/Manifest b/games-arcade/vor/Manifest
index 658ed76cd43f..8b1bd849bb31 100644
--- a/games-arcade/vor/Manifest
+++ b/games-arcade/vor/Manifest
@@ -1 +1,2 @@
DIST vor-0.5.7.tgz 358032 BLAKE2B 96813207a8529d6a7ae5863811fa02666d51b4108afd96cf5b4aed0405d6cc32668f0a7abfbc571141877803a15678c46c8664fe3599cd12e0c6fe95ab5d880f SHA512 32dbfe95971298f9f0191cc95fdb5e9ec34c5f6771df1566554b128644770bfba618df3aac7242e647c8af2f41fc59c9e5620a4c56932d3af72197f6a19f0bce
+DIST vor-0.5.8.tgz 361789 BLAKE2B b6391a03d175520ef97db7c4b80425f6f15193614f5e582b4d96019ce426b9ea21b93e9f503e5e22d5f976fe938cc883e4810803b2942ee3e373025397045c2a SHA512 95633e54c09f947c3e256fc07b1d7c061e98f69b89ce459b7736174410b7f021f4384afe65ec58eb6b89933cb6c8fe166b4491078b98671ae12640c6fc7019f5
diff --git a/games-arcade/vor/vor-0.5.8.ebuild b/games-arcade/vor/vor-0.5.8.ebuild
new file mode 100644
index 000000000000..2bc45bd9b394
--- /dev/null
+++ b/games-arcade/vor/vor-0.5.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Variations on Rockdodger: Dodge the rocks until you die"
+HOMEPAGE="https://jasonwoof.org/vor"
+SRC_URI="https://jasonwoof.com/downloads/vor/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dodir /usr/bin
+
+ default
+
+ newicon data/icon.png ${PN}.png
+ make_desktop_entry ${PN} VoR
+}