summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-07 12:54:25 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-07 12:54:25 +0200
commit864b9d0084966c7812a9376b45bc26ff6cbbf885 (patch)
tree119e2848f97a6bccf368ca084b4507321532b00a /games-arcade
parentgames-arcade/supertux: fix GCC 12 build (diff)
downloadgentoo-864b9d0084966c7812a9376b45bc26ff6cbbf885.tar.gz
gentoo-864b9d0084966c7812a9376b45bc26ff6cbbf885.tar.bz2
gentoo-864b9d0084966c7812a9376b45bc26ff6cbbf885.zip
games-arcade/supertux: drop 0.6.2-r2
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/supertux/Manifest1
-rw-r--r--games-arcade/supertux/supertux-0.6.2-r2.ebuild70
2 files changed, 0 insertions, 71 deletions
diff --git a/games-arcade/supertux/Manifest b/games-arcade/supertux/Manifest
index 4fe1b6e31bdb..0af22cd61c13 100644
--- a/games-arcade/supertux/Manifest
+++ b/games-arcade/supertux/Manifest
@@ -1,2 +1 @@
-DIST SuperTux-v0.6.2-Source.tar.gz 174295862 BLAKE2B 1179a5ecf92dfb2ac56b87afe4fed21a2bdc1d7f91641fea8aafc2994ccfe49745420411f41b2145f06fa9714c73d75ecbc85160e85edcbd71c472026cefe708 SHA512 5baa783ee589b42a9bbce3740659dbb7b617ebfcc00c0a038c03d31b56700e3923c8548700ccebe42b325ca03bd85186bc5edef9f6580d93dc48d8aca88cbf74
DIST SuperTux-v0.6.3-Source.tar.gz 182065428 BLAKE2B c4acbe2c61306e6e462a375205b4e95af174c87dbc391f15211e1fac365ab51147d7a83d20a90e35f7d7a994c72b560631ddf1686fee2e1f937f97a711fb1003 SHA512 c6540bab1b3befbd975756031c4587e5569d9613d9539dc829c728b574d1a4da92816d6a7e68947b32963cc13d9b8b52312701c199138640e9f89e5885433798
diff --git a/games-arcade/supertux/supertux-0.6.2-r2.ebuild b/games-arcade/supertux/supertux-0.6.2-r2.ebuild
deleted file mode 100644
index 76a941ef3820..000000000000
--- a/games-arcade/supertux/supertux-0.6.2-r2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-: ${CMAKE_MAKEFILE_GENERATOR:=emake}
-inherit cmake flag-o-matic
-
-MY_PV="${PV/_rc/-rc.}"
-MY_P="SuperTux-v${MY_PV}-Source"
-
-DESCRIPTION="A game similar to Super Mario Bros"
-HOMEPAGE="https://supertux.org/"
-SRC_URI="https://github.com/SuperTux/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2+ GPL-3+ ZLIB MIT CC-BY-SA-2.0 CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="debug"
-
-# =media-libs/libsdl2-2.0.14-r0 can cause supertux binary to move entire
-# content of ${HOME} to ${HOME}/.local/share/supertux2/
-# DO NOT REMOVE THIS BLOCKER!!! See bug #764959
-RDEPEND="
- !=media-libs/libsdl2-2.0.14-r0
- >=dev-games/physfs-3.0
- dev-libs/boost:=[nls]
- media-libs/freetype
- media-libs/glew:=
- media-libs/libpng:0=
- >=media-libs/libsdl2-2.0.1[joystick,video]
- media-libs/libvorbis
- media-libs/openal
- >=media-libs/sdl2-image-2.0.0[png,jpeg]
- >=net-misc/curl-7.21.7
- virtual/opengl
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
-"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.5.0-tinygettext.patch
- "${FILESDIR}"/${PN}-0.6.0-{license,icon,obstack}.patch
-)
-
-src_prepare() {
- cmake_src_prepare
-
- # This is not a developer release so switch the logo to the non-dev one.
- sed -e 's@logo_dev@logo@' \
- -i data/images/objects/logo/logo.sprite || die
-}
-
-src_configure() {
- append-cxxflags -std=c++11
-
- local mycmakeargs=(
- -DWERROR=OFF
- -DINSTALL_SUBDIR_BIN=bin
- -DINSTALL_SUBDIR_DOC=share/doc/${PF}
- -DINSTALL_SUBDIR_SHARE=share/${PN}2
- -DENABLE_SQDBG="$(usex debug)"
- -DUSE_SYSTEM_PHYSFS=ON
- )
- cmake_src_configure
-}