summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/gmchess/files/gmchess-0.29.6-gentoo.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/gmchess/files/gmchess-0.29.6-gentoo.patch')
-rw-r--r--games-board/gmchess/files/gmchess-0.29.6-gentoo.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-board/gmchess/files/gmchess-0.29.6-gentoo.patch b/games-board/gmchess/files/gmchess-0.29.6-gentoo.patch
new file mode 100644
index 000000000000..0952cda306b1
--- /dev/null
+++ b/games-board/gmchess/files/gmchess-0.29.6-gentoo.patch
@@ -0,0 +1,46 @@
+diff -ru gmchess-0.29.6.orig/configure.in gmchess-0.29.6/configure.in
+--- gmchess-0.29.6.orig/configure.in 2011-11-28 07:22:56.000000000 -0500
++++ gmchess-0.29.6/configure.in 2013-05-13 21:30:38.103817044 -0400
+@@ -4,7 +4,7 @@
+ AC_PREREQ([2.63])
+ AC_INIT(gmchess, 0.29.6, lerosua@gmail.com)
+ AC_CONFIG_SRCDIR([src/Pgnfile.cc])
+-AM_CONFIG_HEADER([config.h])
++AC_CONFIG_HEADERS([config.h])
+ AM_INIT_AUTOMAKE(gmchess,0.29.6)
+
+
+diff -ru gmchess-0.29.6.orig/data/gmchess.desktop.in gmchess-0.29.6/data/gmchess.desktop.in
+--- gmchess-0.29.6.orig/data/gmchess.desktop.in 2009-09-07 08:08:47.000000000 -0400
++++ gmchess-0.29.6/data/gmchess.desktop.in 2013-05-13 21:30:19.444462390 -0400
+@@ -1,4 +1,3 @@
+-
+ [Desktop Entry]
+ Name=Chinese chess
+ Name[zh_CN]=天书棋谈
+@@ -10,4 +9,3 @@
+ Type=Application
+ Categories=GNOME;GTK;Game;BoardGame;
+ StartupNotify=true
+-Encoding=UTF-8
+diff -ru gmchess-0.29.6.orig/src/engine/eleeye.cpp gmchess-0.29.6/src/engine/eleeye.cpp
+--- gmchess-0.29.6.orig/src/engine/eleeye.cpp 2011-10-26 08:01:39.000000000 -0400
++++ gmchess-0.29.6/src/engine/eleeye.cpp 2013-05-13 21:30:19.445462355 -0400
+@@ -35,7 +35,7 @@
+ #elif __linux__
+ #include <dlfcn.h>
+ #define WINAPI
+- const char *const cszLibEvalFile = "../lib/libeval.so.0";
++ const char *const cszLibEvalFile = "GAMES_LIBDIR/libeval.so.0";
+ #elif __APPLE__
+ #include <dlfcn.h>
+ const char *const cszLibEvalFile = "/usr/local/lib/libeval.0.dylib";
+@@ -125,7 +125,7 @@
+ if (BootLine() != UCCI_COMM_UCCI) {
+ return 0;
+ }
+- LocatePath(Search.szBookFile, "../share/gmchess/book.dat");
++ LocatePath(Search.szBookFile, "GAMES_DATADIR/book.dat");
+ //LocatePath(Search.szBookFile, "book.dat");
+ LocatePath(szLibEvalFile, cszLibEvalFile);
+ hModule = LoadEvalApi(szLibEvalFile);