summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-09-16 01:20:10 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-09-21 22:12:02 +0100
commit6c8fbcf2f15b94c6fd846688677e69ee9cdae554 (patch)
tree2cb1bdba5a7f568895089fd8cd405868a32951b8 /games-emulation/gngeo/gngeo-0.8-r2.ebuild
parentdev-games/ogre: Version bump to 1.12.9 (diff)
downloadgentoo-6c8fbcf2f15b94c6fd846688677e69ee9cdae554.tar.gz
gentoo-6c8fbcf2f15b94c6fd846688677e69ee9cdae554.tar.bz2
gentoo-6c8fbcf2f15b94c6fd846688677e69ee9cdae554.zip
games-emulation/gngeo: fix build with gcc 10
Closes: https://bugs.gentoo.org/708062 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-emulation/gngeo/gngeo-0.8-r2.ebuild')
-rw-r--r--games-emulation/gngeo/gngeo-0.8-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-emulation/gngeo/gngeo-0.8-r2.ebuild b/games-emulation/gngeo/gngeo-0.8-r2.ebuild
new file mode 100644
index 000000000000..f4e1e906ad79
--- /dev/null
+++ b/games-emulation/gngeo/gngeo-0.8-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop flag-o-matic
+
+DESCRIPTION="A NeoGeo emulator"
+HOMEPAGE="https://code.google.com/p/gngeo/"
+SRC_URI="https://gngeo.googlecode.com/files/${P}.tar.gz
+ https://storage.googleapis.com/google-code-archive/v2/code.google.com/gngeo/logo.png -> ${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ media-libs/libsdl[joystick,opengl,sound,video]
+ sys-libs/zlib[minizip]
+ virtual/opengl
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-execstacks.patch
+ "${FILESDIR}"/${P}-zlib.patch
+ "${FILESDIR}"/${P}-concurrentMake.patch
+ "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-fcommon.patch
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die
+ eautoreconf
+ append-cflags -std=gnu89 # build with gcc5 (bug #571056)
+}
+
+src_configure() {
+ econf --disable-i386asm
+}
+
+src_install() {
+ DOCS=( AUTHORS FAQ NEWS README* TODO sample_gngeorc )
+ default
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN}
+}