summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/gngeo/gngeo-0.8-r2.ebuild')
-rw-r--r--games-emulation/gngeo/gngeo-0.8-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-emulation/gngeo/gngeo-0.8-r2.ebuild b/games-emulation/gngeo/gngeo-0.8-r2.ebuild
new file mode 100644
index 000000000000..f4e1e906ad79
--- /dev/null
+++ b/games-emulation/gngeo/gngeo-0.8-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop flag-o-matic
+
+DESCRIPTION="A NeoGeo emulator"
+HOMEPAGE="https://code.google.com/p/gngeo/"
+SRC_URI="https://gngeo.googlecode.com/files/${P}.tar.gz
+ https://storage.googleapis.com/google-code-archive/v2/code.google.com/gngeo/logo.png -> ${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ media-libs/libsdl[joystick,opengl,sound,video]
+ sys-libs/zlib[minizip]
+ virtual/opengl
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-execstacks.patch
+ "${FILESDIR}"/${P}-zlib.patch
+ "${FILESDIR}"/${P}-concurrentMake.patch
+ "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-fcommon.patch
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die
+ eautoreconf
+ append-cflags -std=gnu89 # build with gcc5 (bug #571056)
+}
+
+src_configure() {
+ econf --disable-i386asm
+}
+
+src_install() {
+ DOCS=( AUTHORS FAQ NEWS README* TODO sample_gngeorc )
+ default
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN}
+}