summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-22 03:12:43 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-22 03:24:48 -0400
commit78906e6348e0041db33e5a77ea68cd73626a7803 (patch)
tree851f4429bd092cefb532e6ec570d8a1fd21c9b17 /games-emulation/pcsx2_patches
parentgames-emulation/pcsx2_patches: drop 0_p20231217, 0_p20240116 (diff)
downloadgentoo-78906e6348e0041db33e5a77ea68cd73626a7803.tar.gz
gentoo-78906e6348e0041db33e5a77ea68cd73626a7803.tar.bz2
gentoo-78906e6348e0041db33e5a77ea68cd73626a7803.zip
games-emulation/pcsx2_patches: add 0_p20240416
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/pcsx2_patches')
-rw-r--r--games-emulation/pcsx2_patches/Manifest1
-rw-r--r--games-emulation/pcsx2_patches/pcsx2_patches-0_p20240416.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/games-emulation/pcsx2_patches/Manifest b/games-emulation/pcsx2_patches/Manifest
index 920509682688..e30536e954e5 100644
--- a/games-emulation/pcsx2_patches/Manifest
+++ b/games-emulation/pcsx2_patches/Manifest
@@ -1 +1,2 @@
DIST pcsx2_patches-0_p20240312.tar.gz 664671 BLAKE2B 3061297d147db103a24c7c20c81723fd0f602ec22b38ab12624816c812431ca7440d8dea15ada71e18fc3da480ddcee50a19bf2186274640f3f3dc264795b0b7 SHA512 400cde1c18e7bb2472ddecf96ae918830cbdc6d61fb12f392d0aeda6219f75cf597440c96c6ae1defaea4e2298925833548a473d3c7000f22e20dedbe0f401b7
+DIST pcsx2_patches-0_p20240416.tar.gz 670438 BLAKE2B e3d9692f89e8b141c816fb433980afc3846c48579b89f2310b9368767c943e74664a880c889dd35f9820db492b2d47ab7828fdd8604d034b941156c10edf4290 SHA512 63c52416c78b35a964427d587967cb709657ff914ab9fb0670b6cf67582ee765e8401e5ada747cdd2486b11ecf8a99e3054335ebb0f0d95b1fea926a2a55ec7e
diff --git a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20240416.ebuild b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20240416.ebuild
new file mode 100644
index 000000000000..198c47008fcd
--- /dev/null
+++ b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20240416.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PCSX2/pcsx2_patches.git"
+else
+ HASH_PCSX2_PATCHES=0f52d8a5eb1cefea8b416532ce6ba225271e267f
+ SRC_URI="
+ https://github.com/PCSX2/pcsx2_patches/archive/${HASH_PCSX2_PATCHES}.tar.gz
+ -> ${P}.tar.gz
+ "
+ S=${WORKDIR}/${PN}-${HASH_PCSX2_PATCHES}
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Collection of game patches for use with PCSX2 (e.g. widescreen hacks)"
+HOMEPAGE="https://github.com/PCSX2/pcsx2_patches/"
+
+# these are normally distributed by upstream with PCSX2 which is GPL-3+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_compile() {
+ # upstream uses a constantly replaced "latest" patches.zip (currently no
+ # real releases), and github's .zip archives cannot be used either due to
+ # having the patches/ subdirectory -- so we use a snapshot and repack
+ # (could use app-arch/zip, but python is more likely to skip a dependency)
+ ebegin "Creating patches.zip"
+ "${PYTHON}" - <<-EOF
+ import pathlib
+ from zipfile import ZipFile, ZIP_DEFLATED
+
+ patches = pathlib.Path("patches/")
+
+ with ZipFile("patches.zip", "w", ZIP_DEFLATED, compresslevel=9) as archive:
+ for file in patches.iterdir():
+ archive.write(file, arcname=file.name)
+ EOF
+ eend ${?} || die
+}
+
+src_install() {
+ insinto /usr/lib/pcsx2/resources
+ doins patches.zip
+
+ einstalldocs
+}