summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-06-09 01:59:47 +0300
committerStefan Strogin <steils@gentoo.org>2020-06-09 02:03:40 +0300
commit8620817027b36a4a70349dc516c5b658e160a262 (patch)
treef0c36a52576ca7ac29fa19c1513856e5d6db427f /games-misc/openmsx/openmsx-0.3.1-r4.ebuild
parentprofiles: mask sys-libs/pam-1.4.0 for testing (diff)
downloadgentoo-8620817027b36a4a70349dc516c5b658e160a262.tar.gz
gentoo-8620817027b36a4a70349dc516c5b658e160a262.tar.bz2
gentoo-8620817027b36a4a70349dc516c5b658e160a262.zip
games-misc/openmsx: fix Python 3 patch; add python3_8
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'games-misc/openmsx/openmsx-0.3.1-r4.ebuild')
-rw-r--r--games-misc/openmsx/openmsx-0.3.1-r4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-misc/openmsx/openmsx-0.3.1-r4.ebuild b/games-misc/openmsx/openmsx-0.3.1-r4.ebuild
new file mode 100644
index 000000000000..9edc7a8b3e3d
--- /dev/null
+++ b/games-misc/openmsx/openmsx-0.3.1-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1
+
+DESCRIPTION="Open source music base set for OpenTTD"
+HOMEPAGE="https://wiki.openttd.org/OpenMSX https://github.com/OpenTTD/OpenMSX"
+SRC_URI="https://cdn.openttd.org/openmsx-releases/${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=( "${FILESDIR}"/${P}-python3.patch )
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_compile() {
+ emake _V= bundle
+}
+
+src_install() {
+ insinto "/usr/share/games/openttd/gm/${P}"
+ doins ${P}/{*.mid,openmsx.obm}
+ dodoc ${P}/{changelog.txt,readme.txt}
+}