summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-16 00:31:08 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-16 02:29:39 -0500
commit08efb38659779f40aa9ec3bc79ce9216dd13a84f (patch)
treeef0764194ee66112e3bb7e1f04f45fbf34af3aac /games-puzzle/pingus/pingus-0.7.6-r3.ebuild
parentgames-board/scid: EAPI7->8, enable py3.11 (diff)
downloadgentoo-08efb38659779f40aa9ec3bc79ce9216dd13a84f.tar.gz
gentoo-08efb38659779f40aa9ec3bc79ce9216dd13a84f.tar.bz2
gentoo-08efb38659779f40aa9ec3bc79ce9216dd13a84f.zip
games-puzzle/pingus: EAPI7->8, enable py3.11
scons junk seems to work 3.11 still, ebuild could need more attention but given upstream has removed scons it's likely not worth spending time on (then again, it may be a long time before a release still, development seem to have slowed down). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle/pingus/pingus-0.7.6-r3.ebuild')
-rw-r--r--games-puzzle/pingus/pingus-0.7.6-r3.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/games-puzzle/pingus/pingus-0.7.6-r3.ebuild b/games-puzzle/pingus/pingus-0.7.6-r3.ebuild
deleted file mode 100644
index 4ab22971d918..000000000000
--- a/games-puzzle/pingus/pingus-0.7.6-r3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-inherit desktop flag-o-matic python-any-r1 scons-utils toolchain-funcs xdg
-
-DESCRIPTION="Free Lemmings clone"
-HOMEPAGE="https://pingus.gitlab.io/"
-SRC_URI="https://pingus.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="opengl music"
-
-RDEPEND="
- media-libs/libsdl[joystick,opengl?,video]
- media-libs/sdl-image[png]
- media-libs/sdl-mixer
- music? ( media-libs/sdl-mixer[mod] )
- opengl? ( virtual/opengl )
- media-libs/libpng:0=
- dev-libs/boost:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${P}-noopengl.patch
- "${FILESDIR}"/${P}-gcc47.patch
- "${FILESDIR}"/${P}-echo-e.patch
- "${FILESDIR}"/${P}-gcc7.patch
- "${FILESDIR}"/${P}-boost_signals2.patch
- "${FILESDIR}"/${P}-python3.patch
-)
-
-src_prepare() {
- xdg_src_prepare
- strip-flags
-}
-
-src_compile() {
- escons \
- CXX="$(tc-getCXX)" \
- CCFLAGS="${CXXFLAGS}" \
- LINKFLAGS="${LDFLAGS}" \
- with_opengl=$(usex opengl 1 0)
-}
-
-src_install() {
- emake install-exec install-data \
- DESTDIR="${D}" \
- PREFIX="${EPREFIX}"/usr
- doman doc/man/pingus.6
- doicon data/images/icons/pingus.svg
- make_desktop_entry ${PN} Pingus
- einstalldocs
-}