summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 16:22:58 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:34:20 +0200
commit0acb93c887c99bd26b558da2b73ba1888dba8c37 (patch)
treec712fc16eafe6e1372a08363f19af3d1ddada77b /games-puzzle/tetrinet/tetrinet-0.11-r1.ebuild
parentgames-puzzle/tanglet: Drop old (diff)
downloadgentoo-0acb93c887c99bd26b558da2b73ba1888dba8c37.tar.gz
gentoo-0acb93c887c99bd26b558da2b73ba1888dba8c37.tar.bz2
gentoo-0acb93c887c99bd26b558da2b73ba1888dba8c37.zip
games-puzzle/tetrinet: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/tetrinet/tetrinet-0.11-r1.ebuild')
-rw-r--r--games-puzzle/tetrinet/tetrinet-0.11-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-puzzle/tetrinet/tetrinet-0.11-r1.ebuild b/games-puzzle/tetrinet/tetrinet-0.11-r1.ebuild
new file mode 100644
index 000000000000..013dcef24a21
--- /dev/null
+++ b/games-puzzle/tetrinet/tetrinet-0.11-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Console based tetrinet inc. standalone server"
+HOMEPAGE="http://tetrinet.or.cz/"
+SRC_URI="http://tetrinet.or.cz/download/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6"
+
+RDEPEND=">=sys-libs/ncurses-5:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}"/${P}-no-ipv6.patch \
+ "${FILESDIR}"/${P}-build.patch
+
+ use ipv6 && append-cflags -DHAVE_IPV6
+ tc-export PKG_CONFIG
+}
+
+src_install() {
+ dobin tetrinet tetrinet-server
+ dodoc README TODO tetrinet.txt
+}