summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 02:02:09 +0100
committerSam James <sam@gentoo.org>2021-04-06 19:17:47 +0100
commit9740aaa8317f5268fa4c121b2cd53f75fecc30dc (patch)
tree2d0016146bfbe1b4c5deadaeebb5622c0068aa64 /games-puzzle
parentgames-puzzle/splice: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-9740aaa8317f5268fa4c121b2cd53f75fecc30dc.tar.gz
gentoo-9740aaa8317f5268fa4c121b2cd53f75fecc30dc.tar.bz2
gentoo-9740aaa8317f5268fa4c121b2cd53f75fecc30dc.zip
games-puzzle/tiny-and-big: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/tiny-and-big/tiny-and-big-1.4.1-r1.ebuild (renamed from games-puzzle/tiny-and-big/tiny-and-big-1.4.1.ebuild)31
1 files changed, 15 insertions, 16 deletions
diff --git a/games-puzzle/tiny-and-big/tiny-and-big-1.4.1.ebuild b/games-puzzle/tiny-and-big/tiny-and-big-1.4.1-r1.ebuild
index d8b650922b2f..e19bbc2b3a3c 100644
--- a/games-puzzle/tiny-and-big/tiny-and-big-1.4.1.ebuild
+++ b/games-puzzle/tiny-and-big/tiny-and-big-1.4.1-r1.ebuild
@@ -1,36 +1,36 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# TODO: unbundle media-libs/cal3d, lib hacked or old version
-
-EAPI=5
+EAPI=7
-inherit eutils games
+inherit desktop wrapper
DESCRIPTION="Combines elements of adventure, jump&run and physical puzzles"
HOMEPAGE="http://www.tinyandbig.com/"
SRC_URI="tinyandbig_grandpasleftovers-retail-linux-${PV}_1370968537.tar.bz2"
+S="${WORKDIR}"/tinyandbig
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="bundled-libs"
+
RESTRICT="bindist fetch bundled-libs? ( splitdebug )"
-MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+MYGAMEDIR=opt/${PN}
QA_PREBUILT="${MYGAMEDIR#/}/bin32/*
${MYGAMEDIR#/}/bin64/*"
-DEPEND="app-arch/bzip2"
+# TODO: unbundle media-libs/cal3d, lib hacked or old version
RDEPEND="
- virtual/opengl
media-libs/openal
+ virtual/opengl
x11-libs/libX11
!bundled-libs? (
media-gfx/nvidia-cg-toolkit
- )"
-
-S=${WORKDIR}/tinyandbig
+ )
+"
+BDEPEND="app-arch/bzip2"
pkg_nofetch() {
einfo "Please buy & download ${SRC_URI} from:"
@@ -40,7 +40,7 @@ pkg_nofetch() {
}
src_prepare() {
- if use !bundled-libs ; then
+ if ! use bundled-libs ; then
rm -v $(usex amd64 "bin64" "bin32")/libCg{,GL}.so || die "unbundling libs failed!"
fi
}
@@ -48,13 +48,12 @@ src_prepare() {
src_install() {
local bindir=$(usex amd64 "bin64" "bin32")
- insinto "${MYGAMEDIR}"
+ insinto ${MYGAMEDIR}
doins -r assets ${bindir}
- games_make_wrapper ${PN} "./${bindir}/tinyandbig" "${MYGAMEDIR}" "${MYGAMEDIR}/${bindir}"
+ make_wrapper ${PN} "./${bindir}/tinyandbig" "${MYGAMEDIR}" "${MYGAMEDIR}/${bindir}"
make_desktop_entry ${PN} "Tiny & Big"
dodoc readme.txt
- fperms +x "${MYGAMEDIR}"/${bindir}/tinyandbig
- prepgamesdirs
+ fperms +x ${MYGAMEDIR}/${bindir}/tinyandbig
}