summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-12-10 17:29:36 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-12-10 17:29:36 +0000
commit377a4f55ca08275038f4314a852bb2cef9653886 (patch)
tree75de7f07b1b548ae7a1a85805748d6a75c61288d /games-rpg
parentdev-php/pecl-apcu_bc: Drop 7.1 target; Update deps for unknown targets (diff)
downloadgentoo-377a4f55ca08275038f4314a852bb2cef9653886.tar.gz
gentoo-377a4f55ca08275038f4314a852bb2cef9653886.tar.bz2
gentoo-377a4f55ca08275038f4314a852bb2cef9653886.zip
games-rpg/dungeon-defenders: Use system SDL2, no bundled libs, EAPI 7
This was packaged before SDL2 was released. The bundled version no longer works properly for me so just drop the bundled-libs flag. Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/dungeon-defenders/dungeon-defenders-20130305-r1.ebuild68
-rw-r--r--games-rpg/dungeon-defenders/dungeon-defenders-20130305.ebuild101
-rw-r--r--games-rpg/dungeon-defenders/metadata.xml5
3 files changed, 68 insertions, 106 deletions
diff --git a/games-rpg/dungeon-defenders/dungeon-defenders-20130305-r1.ebuild b/games-rpg/dungeon-defenders/dungeon-defenders-20130305-r1.ebuild
new file mode 100644
index 000000000000..e6bbd621a3e8
--- /dev/null
+++ b/games-rpg/dungeon-defenders/dungeon-defenders-20130305-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit check-reqs desktop unpacker wrapper xdg
+
+TIMESTAMP="${PV:4:2}${PV:6:2}${PV:0:4}"
+DESCRIPTION="A hybrid of two hot genres: Tower Defense and cooperative online Action-RPG"
+HOMEPAGE="https://www.humblebundle.com/store/dungeon-defenders-collection"
+SRC_URI="dundef-linux-${TIMESTAMP}.mojo.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+"
+RDEPEND="
+ media-libs/libsdl2[abi_x86_32,opengl,video]
+ media-libs/openal[abi_x86_32]
+ virtual/opengl[abi_x86_32]
+ x11-misc/xdg-utils
+"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+CHECKREQS_DISK_BUILD="5916M"
+S="${WORKDIR}/data"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ default
+
+ # https://bugzilla.icculus.org/show_bug.cgi?id=5894
+ sed -i 's/LobbyLevel_Valentines2013\.udk/LobbyLevel.udk/' UDKGame/Config/DefaultDunDef.ini || die
+
+ # Remove bundled binaries.
+ rm -v UDKGame/Binaries/{*.so*,xdg-open} || die
+}
+
+src_install() {
+ # Move the data rather than copying. The game consumes over 5GB so a
+ # needless copy should really be avoided!
+ dodir "${DIR}"
+ mv -v Engine/ UDKGame/ "${ED}${DIR}" || die
+
+ # Use system xdg-open script, location is hardcoded.
+ dosym ../../../../usr/bin/xdg-open "${DIR}"/UDKGame/Binaries/xdg-open
+
+ make_wrapper ${PN} ./DungeonDefenders-x86 "${DIR}"/UDKGame/Binaries
+ newicon -s 48 DunDefIcon.png ${PN}.png
+ make_desktop_entry ${PN} "Dungeon Defenders"
+
+ dodoc README-linux.txt
+}
diff --git a/games-rpg/dungeon-defenders/dungeon-defenders-20130305.ebuild b/games-rpg/dungeon-defenders/dungeon-defenders-20130305.ebuild
deleted file mode 100644
index 01a66c03c0a8..000000000000
--- a/games-rpg/dungeon-defenders/dungeon-defenders-20130305.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# TODO: unbundle SDL-2 when it gets released
-
-EAPI=5
-inherit check-reqs eutils gnome2-utils unpacker games
-
-TIMESTAMP="${PV:4:2}${PV:6:2}${PV:0:4}"
-MY_PN="DungeonDefenders"
-DESCRIPTION="A hybrid of two hot genres: Tower Defense and cooperative online Action-RPG"
-HOMEPAGE="http://dungeondefenders.com/"
-SRC_URI="dundef-linux-${TIMESTAMP}.mojo.run"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE="bundled-libs"
-RESTRICT="bindist fetch splitdebug"
-
-MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
-QA_PREBUILT="${MYGAMEDIR#/}/UDKGame/Binaries/${MY_PN}-x86
- ${MYGAMEDIR#/}/UDKGame/Binaries/libSDL2-2.0.so.0"
-CHECKREQS_DISK_BUILD="5916M"
-
-# linked against pulseaudio
-# without SDL-2 only linkage: opengl, openal
-DEPEND="app-arch/unzip"
-RDEPEND="
- x11-misc/xdg-utils
- >=media-libs/alsa-lib-1.0.27.2[abi_x86_32(-)]
- >=media-sound/pulseaudio-5.0[abi_x86_32(-)]
- virtual/opengl[abi_x86_32(-)]
- x11-libs/libX11[abi_x86_32(-)]
- x11-libs/libXScrnSaver[abi_x86_32(-)]
- x11-libs/libXcursor[abi_x86_32(-)]
- x11-libs/libXext[abi_x86_32(-)]
- x11-libs/libXi[abi_x86_32(-)]
- x11-libs/libXinerama[abi_x86_32(-)]
- x11-libs/libXrandr[abi_x86_32(-)]
- x11-libs/libXxf86vm[abi_x86_32(-)]
- !bundled-libs? ( >=media-libs/openal-1.15.1[abi_x86_32(-)] )"
-
-S=${WORKDIR}/data
-
-pkg_nofetch() {
- einfo "Please buy & download ${SRC_URI} from:"
- einfo " ${HOMEPAGE}"
- einfo "and move it to your DISTDIR directory."
- einfo
-}
-
-src_unpack() {
- unpack_zip ${A}
-}
-
-src_prepare() {
- # https://bugzilla.icculus.org/show_bug.cgi?id=5894
- sed -i \
- -e 's/LobbyLevel_Valentines2013.udk/LobbyLevel.udk/' \
- UDKGame/Config/DefaultDunDef.ini || die
-
- # Remove the binaries that we're unbundling and unnecessary stuff
- rm -v UDKGame/Binaries/xdg-open || die
- if ! use bundled-libs ; then
- einfo "Removing bundled libs..."
- rm -v UDKGame/Binaries/libopenal.so.1 || die
- fi
-}
-
-src_install() {
- # Move the data rather than copying. The game consumes over 5GB so
- # a needless copy should really be avoided!
- dodir "${MYGAMEDIR}"
- mv -v Engine UDKGame "${D}${MYGAMEDIR}" || die
-
- # use system xdg-open script, location is hardcoded
- dosym /usr/bin/xdg-open "${MYGAMEDIR}"/UDKGame/Binaries/xdg-open
-
- newicon -s 48 DunDefIcon.png ${PN}.png
- make_desktop_entry "${PN}" "Dungeon Defenders"
- games_make_wrapper ${PN} "./${MY_PN}-x86" "${MYGAMEDIR}/UDKGame/Binaries"
-
- dodoc README-linux.txt
-
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-rpg/dungeon-defenders/metadata.xml b/games-rpg/dungeon-defenders/metadata.xml
index b878aaa1812d..26079e608bed 100644
--- a/games-rpg/dungeon-defenders/metadata.xml
+++ b/games-rpg/dungeon-defenders/metadata.xml
@@ -5,9 +5,4 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
- <use>
- <flag name="bundled-libs">
- Use the upstream provided bundled libraries.
- </flag>
- </use>
</pkgmetadata>