summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/wiiload
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/wiiload')
-rw-r--r--games-util/wiiload/Manifest1
-rw-r--r--games-util/wiiload/metadata.xml5
-rw-r--r--games-util/wiiload/wiiload-0.5.ebuild23
3 files changed, 29 insertions, 0 deletions
diff --git a/games-util/wiiload/Manifest b/games-util/wiiload/Manifest
new file mode 100644
index 000000000000..42c6bf4225c1
--- /dev/null
+++ b/games-util/wiiload/Manifest
@@ -0,0 +1 @@
+DIST wiiload-0.5.tar.gz 5291 SHA256 49da2326b43d95a5414d2491ba5a28bd5b97fbafecb1f40b79319213460fa912 SHA512 2c13490e5034078fef658ca3f9743be04fd6c870e485aae7be21a80967f2d1f1075fee016bf7945b20004bc5d96d0b3244f8a997c4410299f1f6afca002360e4 WHIRLPOOL d89ce7eb15151924365f15bd8dff8a8c6198be52ca171be24fda91f39e47958e2f22e7a005959b6ee5199df8aef657af6632419fc928bb147f94369ea9b1e6bf
diff --git a/games-util/wiiload/metadata.xml b/games-util/wiiload/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-util/wiiload/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-util/wiiload/wiiload-0.5.ebuild b/games-util/wiiload/wiiload-0.5.ebuild
new file mode 100644
index 000000000000..f225227b4c73
--- /dev/null
+++ b/games-util/wiiload/wiiload-0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="load homebrew apps over the network to your Wii"
+HOMEPAGE="http://wiibrew.org/wiki/Wiiload"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin wiiload
+}