summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-17 18:31:06 -0400
committerSam James <sam@gentoo.org>2024-03-18 05:29:50 +0000
commit06efe65453313382b27208caa2f13b6e9d39dec1 (patch)
tree02612cacb76bbe2f2dec0cc82c7e3dc019a8d5cf /games-util
parentgames-util/wit: mark as LTO-unsafe (diff)
downloadgentoo-06efe65453313382b27208caa2f13b6e9d39dec1.tar.gz
gentoo-06efe65453313382b27208caa2f13b6e9d39dec1.tar.bz2
gentoo-06efe65453313382b27208caa2f13b6e9d39dec1.zip
games-util/wit: update EAPI 7 -> 8
Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/wit/wit-3.02a-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/games-util/wit/wit-3.02a-r1.ebuild b/games-util/wit/wit-3.02a-r1.ebuild
new file mode 100644
index 000000000000..ee7795010df5
--- /dev/null
+++ b/games-util/wit/wit-3.02a-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P="wiimms-iso-tools.source-${PV}"
+
+DESCRIPTION="command line tools to manipulate Wii/GameCube ISO images and WBFS containers"
+HOMEPAGE="https://wit.wiimm.de/"
+SRC_URI="https://download.wiimm.de/source/wiimms-iso-tools/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fuse +zlib"
+
+RDEPEND="
+ app-arch/bzip2:0=
+ fuse? ( sys-fs/fuse:0= )
+ zlib? ( sys-libs/zlib:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-no-exec-stack.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/859319
+ #
+ # After investigation, the build system also uses -fno-strict-aliasing
+ # so do not trust it with LTO either, even if the type-mismatch gets fixed.
+ filter-lto
+
+ export NO_FUSE=$(usex fuse 0 1)
+ export NO_ZLIB=$(usex zlib 0 1)
+
+ tc-export CC PKG_CONFIG
+}
+
+src_compile() {
+ emake INSTALL_PATH="${ED}"/usr
+ emake doc
+}
+
+src_install() {
+ default
+ dodoc doc/*.txt
+}