summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-06-27 20:18:16 -0400
committerAaron Bauman <bman@gentoo.org>2021-01-25 09:55:26 -0500
commitb6cce86b8061287856c9ac3b164401d09790a960 (patch)
tree074ffc94791052c5690910ef175a310b77da0ea8 /gui-apps/wayvnc/wayvnc-9999.ebuild
parentgui-libs/neatvnc: clean vnc library for wayland (diff)
downloadgentoo-b6cce86b8061287856c9ac3b164401d09790a960.tar.gz
gentoo-b6cce86b8061287856c9ac3b164401d09790a960.tar.bz2
gentoo-b6cce86b8061287856c9ac3b164401d09790a960.zip
gui-apps/wayvnc: simple and fast vnc server for wayland
the first vnc server to support wlroots based compositors to enable remote access Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/16461 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps/wayvnc/wayvnc-9999.ebuild')
-rw-r--r--gui-apps/wayvnc/wayvnc-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/gui-apps/wayvnc/wayvnc-9999.ebuild b/gui-apps/wayvnc/wayvnc-9999.ebuild
new file mode 100644
index 000000000000..369ff2e67cac
--- /dev/null
+++ b/gui-apps/wayvnc/wayvnc-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="gbm tracing"
+
+RDEPEND="
+ dev-libs/aml
+ dev-libs/wayland
+ gui-libs/neatvnc[tracing?]
+ media-libs/mesa:=[egl,gles2,gbm?]
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ tracing? ( dev-util/systemtap )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gbm screencopy-dmabuf)
+ $(meson_use tracing systemtap)
+ )
+ meson_src_configure
+}