summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-04-07 12:46:03 -0400
committerYixun Lan <dlan@gentoo.org>2024-04-08 12:52:10 +0000
commit3b1aee3c2e0c51f7969ac2e2a4c9c96ba886a24b (patch)
treea6479e15534a4e3dbcb98c71862ae02ba71ea1b2 /gui-libs/hyprcursor/hyprcursor-0.1.6.ebuild
parentdev-build/cmake: add 3.29.1 (diff)
downloadgentoo-3b1aee3c2e0c51f7969ac2e2a4c9c96ba886a24b.tar.gz
gentoo-3b1aee3c2e0c51f7969ac2e2a4c9c96ba886a24b.tar.bz2
gentoo-3b1aee3c2e0c51f7969ac2e2a4c9c96ba886a24b.zip
gui-libs/hyprcursor: add 0.1.6
Signed-off-by: Julien Roy <julien@jroy.ca> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-libs/hyprcursor/hyprcursor-0.1.6.ebuild')
-rw-r--r--gui-libs/hyprcursor/hyprcursor-0.1.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/gui-libs/hyprcursor/hyprcursor-0.1.6.ebuild b/gui-libs/hyprcursor/hyprcursor-0.1.6.ebuild
new file mode 100644
index 000000000000..25a590acd7d2
--- /dev/null
+++ b/gui-libs/hyprcursor/hyprcursor-0.1.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The hyprland cursor format, library and utilities"
+HOMEPAGE="https://github.com/hyprwm/hyprcursor"
+SRC_URI="https://github.com/hyprwm/hyprcursor/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+# Disable tests since as per upstream, tests require a theme to be installed
+# See also https://github.com/hyprwm/hyprcursor/commit/94361fd8a75178b92c4bb24dcd8c7fac8423acf3
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/hyprlang-0.4.2
+ dev-libs/libzip
+ gnome-base/librsvg:2
+ x11-libs/cairo
+"