summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-11 14:55:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-11 17:36:50 +0200
commit9469c9b2f4cf5cb621ce729730c3b83094966f80 (patch)
tree849fb729d90a723eb00ad0690b96cd678d691366 /kde-frameworks/prison/prison-5.72.0.ebuild
parentkde-frameworks/oxygen-icons: 5.72.0 version bump (diff)
downloadgentoo-9469c9b2f4cf5cb621ce729730c3b83094966f80.tar.gz
gentoo-9469c9b2f4cf5cb621ce729730c3b83094966f80.tar.bz2
gentoo-9469c9b2f4cf5cb621ce729730c3b83094966f80.zip
kde-frameworks/prison: 5.72.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/prison/prison-5.72.0.ebuild')
-rw-r--r--kde-frameworks/prison/prison-5.72.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/prison/prison-5.72.0.ebuild b/kde-frameworks/prison/prison-5.72.0.ebuild
new file mode 100644
index 000000000000..9a2b0ebc07db
--- /dev/null
+++ b/kde-frameworks/prison/prison-5.72.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="QRCode and data matrix barcode library"
+HOMEPAGE="https://invent.kde.org/frameworks/prison"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="qml"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ media-gfx/qrencode:=
+ media-libs/libdmtx
+ qml? ( >=dev-qt/qtdeclarative-${QTMIN}:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt5Quick)
+ )
+
+ ecm_src_configure
+}