summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-30 14:35:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-30 16:32:29 +0200
commit3a88c6f1b382ab5ebfe61539039a694c0e123991 (patch)
tree08f3cf35bc863ba6278e2950b9c5e72e83efe7be /kde-plasma/ksshaskpass/ksshaskpass-5.16.4.ebuild
parentacct-group/kvm: make virtualization the primary maintainer (diff)
downloadgentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.tar.gz
gentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.tar.bz2
gentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.zip
kde-plasma: Add KDE Plasma 5.16.4
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass/ksshaskpass-5.16.4.ebuild')
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.16.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.16.4.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.16.4.ebuild
new file mode 100644
index 000000000000..55652bdcf792
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.16.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}