summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Bamford <neddyseagoon@gentoo.org>2016-06-04 16:23:44 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-06-05 07:30:26 +0000
commit90509a909c8bbce47525761da1af058f5c7a7709 (patch)
treeb5b5103c5233e9af71261bbd031f9a96a2d62165 /mail-filter/spamdyke/spamdyke-5.0.1.ebuild
parentvirtual/qmail: Removed mail-mta/netqmail-1.05 from RDEPEND (diff)
downloadgentoo-90509a909c8bbce47525761da1af058f5c7a7709.tar.gz
gentoo-90509a909c8bbce47525761da1af058f5c7a7709.tar.bz2
gentoo-90509a909c8bbce47525761da1af058f5c7a7709.zip
mail-filter/spamdyke: Added version spamdyke-5.0.1
This addresses bug 548178 which was for spamdyke-5.0.0 Tested on hardened ~amd64 unable to test on ~x86. Package-Manager: portage-2.3.0_rc1 Gentoo-Bug: https://bugs.gentoo.org/548178 Closes: https://github.com/gentoo/gentoo/pull/1606 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'mail-filter/spamdyke/spamdyke-5.0.1.ebuild')
-rw-r--r--mail-filter/spamdyke/spamdyke-5.0.1.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/mail-filter/spamdyke/spamdyke-5.0.1.ebuild b/mail-filter/spamdyke/spamdyke-5.0.1.ebuild
new file mode 100644
index 000000000000..cc117b763b35
--- /dev/null
+++ b/mail-filter/spamdyke/spamdyke-5.0.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="A drop-in connection-time spam filter for qmail"
+HOMEPAGE="http://www.spamdyke.org/"
+SRC_URI="http://www.spamdyke.org/releases/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl +ssl"
+
+DEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )"
+RDEPEND="${DEPEND}
+ virtual/qmail"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_prepare() {
+ echo "# Configuration option for ${PN}" > ${PN}.conf
+ if use ssl; then
+ echo "tls-certificate-file=/var/qmail/control/clientcert.pem" \
+ >> ${PN}.conf
+ fi
+ echo "graylist-level=always-create-dir" >> ${PN}.conf
+ echo "graylist-dir=/var/tmp/${PN}/graylist" >> ${PN}.conf
+ echo "reject-empty-rdns" >> ${PN}.conf
+ echo "reject-unresolvable-rdns" >> ${PN}.conf
+ echo "dns-blacklist-entry=zen.spamhaus.org" >> ${PN}.conf
+ echo "local-domains-file=/var/qmail/control/rcpthosts" >> ${PN}.conf
+ sed -i \
+ -e "/STRIP_CMD/d" \
+ Makefile.in || die "sed on Makefile.in failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable ssl tls) || die "econf failed"
+ cd ../utils
+ econf || die "econf failed in utils"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+ cd ../utils
+ emake CFLAGS="${CFLAGS}" || die "emake in utils died"
+}
+
+src_install() {
+ insinto /etc/${PN}
+ doins ${PN}.conf || die "Installing ${PN} configuration file failed"
+ dodir /var/tmp/${PN}/graylist
+ fowners -R qmaild /var/tmp/${PN}/graylist
+ cd ../utils
+ dobin domain2path || die "Installing domain2path binary failed"
+ cd ../documentation
+ dodoc {Changelog,INSTALL,UPGRADING}.txt
+ dohtml FAQ.html \
+ README.html \
+ README_ip_file_format.html \
+ README_rdns_directory_format.html \
+ README_rdns_file_format.html
+}
+
+pkg_postinst() {
+ ewarn "Change /var/qmail/control/conf-common:SOFTLIMIT_OPTS="-m 16000000""
+ ewarn "to 32000000 or spamdyke will fail to load"
+ elog "In /var/qmail/control/conf-smtpd insert the line:"
+ elog "QMAIL_SMTP_PRE=\"${QMAIL_SMTP_PRE} spamdyke -f /etc/${PN}/${PN}.conf\""
+ elog "Run spamdyke with the '-h' flag to see the available options and"
+ elog "update /etc/spamdyke/spamdyke.conf accordingly"
+}