summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-08-11 23:35:50 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-08-12 01:12:28 -0400
commit39bdd7d511b051099cd7bee3fd1910d6458ebb36 (patch)
treef75a5da0960681ccb50f48e9600302a35042c8cf /mate-extra/mate-system-monitor/mate-system-monitor-1.12.2.ebuild
parentmate-extra/mate-power-manager: 1.12.x vbump, add gtk3, import from project repo (diff)
downloadgentoo-39bdd7d511b051099cd7bee3fd1910d6458ebb36.tar.gz
gentoo-39bdd7d511b051099cd7bee3fd1910d6458ebb36.tar.bz2
gentoo-39bdd7d511b051099cd7bee3fd1910d6458ebb36.zip
mate-extra/mate-system-monitor: 1.12.x vbump, add gtk3, import from project repo
Package-Manager: portage-2.3.0
Diffstat (limited to 'mate-extra/mate-system-monitor/mate-system-monitor-1.12.2.ebuild')
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.12.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.12.2.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.12.2.ebuild
new file mode 100644
index 000000000000..3304a90976b9
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.12.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="gtk3 systemd"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-libs/dbus-glib-0.70:0
+ >=dev-libs/glib-2.36:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.23.1:2=
+ >=gnome-base/librsvg-2.35:2
+ >=sys-apps/dbus-0.7:0
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ virtual/libintl:0
+ !gtk3? (
+ >=dev-cpp/gtkmm-2.22:2.4
+ >=x11-libs/gtk+-2.20:2
+ >=x11-libs/libwnck-2.5:1
+ )
+ gtk3? (
+ >=dev-cpp/gtkmm-3.0:3.0
+ >=x11-libs/gtk+-3.0:3
+ >=x11-libs/libwnck-2.91:3
+ )
+ systemd? ( sys-apps/systemd )"
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/autoconf-2.63:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --with-gtk=$(usex gtk3 3.0 2.0) \
+ $(use_enable systemd)
+}