summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-09-21 13:18:12 +0200
committerSebastian Pipping <sping@gentoo.org>2018-09-21 13:21:16 +0200
commit76860aa860c8656ca8d14b81b6327d4116324eff (patch)
tree165891cab54044e55eb94febe67b3bdb5546e869 /media-fonts/encodings/encodings-1.0.4-r3.ebuild
parentapp-eselect/eselect-repository: Add ~sparc keyword too (diff)
downloadgentoo-76860aa860c8656ca8d14b81b6327d4116324eff.tar.gz
gentoo-76860aa860c8656ca8d14b81b6327d4116324eff.tar.bz2
gentoo-76860aa860c8656ca8d14b81b6327d4116324eff.zip
media-fonts/encodings: Fix xorg-2_src_install shadowing regression
xorg-2_pkg_post* are called to be future proof, only. Closes: https://bugs.gentoo.org/665008 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'media-fonts/encodings/encodings-1.0.4-r3.ebuild')
-rw-r--r--media-fonts/encodings/encodings-1.0.4-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-fonts/encodings/encodings-1.0.4-r3.ebuild b/media-fonts/encodings/encodings-1.0.4-r3.ebuild
new file mode 100644
index 000000000000..af7bb67275f0
--- /dev/null
+++ b/media-fonts/encodings/encodings-1.0.4-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# font eclass is needed since "media-fonts/encodings" does not match
+# check for pattern media-fonts/font* in xorg-2 eclass
+inherit font xorg-2
+
+DESCRIPTION="X.Org font encodings"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="x11-apps/mkfontscale
+ >=media-fonts/font-util-1.1.1-r1"
+
+ECONF_SOURCE="${S}"
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ font_pkg_postinst
+}
+
+pkg_postrm() {
+ xorg-2_pkg_postrm
+ font_pkg_postrm
+}