summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/rawtherapee/files/rawtherapee-4.0.9-no-hg.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/rawtherapee/files/rawtherapee-4.0.9-no-hg.patch')
-rw-r--r--media-gfx/rawtherapee/files/rawtherapee-4.0.9-no-hg.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/files/rawtherapee-4.0.9-no-hg.patch b/media-gfx/rawtherapee/files/rawtherapee-4.0.9-no-hg.patch
new file mode 100644
index 000000000000..18009e80a9a0
--- /dev/null
+++ b/media-gfx/rawtherapee/files/rawtherapee-4.0.9-no-hg.patch
@@ -0,0 +1,60 @@
+--- rawtherapee-4.0.9/CMakeLists.txt
++++ rawtherapee-4.0.9/CMakeLists.txt
+@@ -257,35 +257,7 @@
+ find_file(HG_CMD hg PATHS "/opt/local/bin" "/usr/local/bin" "/usr/bin")
+ find_file(HG_CMD hg)
+
+- else (WIN32)
+-
+- add_custom_target (AboutFile ALL
+- COMMAND ${CMAKE_COMMAND}
+- -DSRC_DIR:STRING=${CMAKE_CURRENT_SOURCE_DIR}
+- -DCACHE_NAME_SUFFIX:STRING=${CACHE_NAME_SUFFIX}
+- -DSYSTEM:STRING=Linux
+- -DPROC_LABEL:STRING=\"${PROC_LABEL}\"
+- -DPROC_BIT_DEPTH:STRING=\"${PROC_BIT_DEPTH}\"
+- -DBUILD_TYPE:STRING=${CMAKE_BUILD_TYPE}
+- -DGTKMM_VERSION:STRING=${GTKMM_VERSION}
+- -DCXX_FLAGS:STRING=${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_${UPPER_CMAKE_BUILD_TYPE}}
+- -DLFLAGS:STRING=${CMAKE_EXE_LINKER_FLAGS} ${CMAKE_EXE_LINKER_FLAGS_${UPPER_CMAKE_BUILD_TYPE}}
+- -DOPTION_OMP:STRING=${OPTION_OMP}
+- -DWITH_MYFILE_MMAP:STRING=${WITH_MYFILE_MMAP}
+- -P ${CMAKE_CURRENT_SOURCE_DIR}/AboutThisBuild.cmake
+- COMMENT "Creating the about file"
+- )
+- find_file(HG_CMD hg)
+-
+ endif (WIN32)
+-
+- add_dependencies(AboutFile Debug Release MinSizeRel RelWithDebInfo)
+-
+- if (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+- message(FATAL_ERROR "hg command not found!")
+- else (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+- message(STATUS "hg command found: ${HG_CMD}")
+- endif (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+
+ endif (AUTOMATED_BUILD_SYSTEM)
+
+@@ -352,7 +324,6 @@
+
+ install (FILES AUTHORS.txt DESTINATION ${CREDITSDIR})
+ install (FILES LICENSE.txt DESTINATION ${LICENCEDIR})
+-install (FILES AboutThisBuild.txt DESTINATION ${CREDITSDIR})
+ install (FILES RELEASE_NOTES.txt DESTINATION ${CREDITSDIR} OPTIONAL)
+
+ add_subdirectory (rtexif)
+--- rawtherapee-4.0.9/rtgui/version.h
++++ rawtherapee-4.0.9/rtgui/version.h
+@@ -0,0 +1,11 @@
++// This file is automatically generated by the Makefile - DO NOT EDIT!
++// You can (should) also tell mercurial to ignore it.
++
++#ifndef _VERSION_
++#define _VERSION_
++
++#define VERSION "4.0.9"
++#define TAGDISTANCE 0
++#define CACHEFOLDERNAME "RawTherapee"
++
++#endif