summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/rawtherapee/files/rawtherapee-4.0.9-no-hg.patch')
-rw-r--r--media-gfx/rawtherapee/files/rawtherapee-4.0.9-no-hg.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/files/rawtherapee-4.0.9-no-hg.patch b/media-gfx/rawtherapee/files/rawtherapee-4.0.9-no-hg.patch
new file mode 100644
index 000000000000..18009e80a9a0
--- /dev/null
+++ b/media-gfx/rawtherapee/files/rawtherapee-4.0.9-no-hg.patch
@@ -0,0 +1,60 @@
+--- rawtherapee-4.0.9/CMakeLists.txt
++++ rawtherapee-4.0.9/CMakeLists.txt
+@@ -257,35 +257,7 @@
+ find_file(HG_CMD hg PATHS "/opt/local/bin" "/usr/local/bin" "/usr/bin")
+ find_file(HG_CMD hg)
+
+- else (WIN32)
+-
+- add_custom_target (AboutFile ALL
+- COMMAND ${CMAKE_COMMAND}
+- -DSRC_DIR:STRING=${CMAKE_CURRENT_SOURCE_DIR}
+- -DCACHE_NAME_SUFFIX:STRING=${CACHE_NAME_SUFFIX}
+- -DSYSTEM:STRING=Linux
+- -DPROC_LABEL:STRING=\"${PROC_LABEL}\"
+- -DPROC_BIT_DEPTH:STRING=\"${PROC_BIT_DEPTH}\"
+- -DBUILD_TYPE:STRING=${CMAKE_BUILD_TYPE}
+- -DGTKMM_VERSION:STRING=${GTKMM_VERSION}
+- -DCXX_FLAGS:STRING=${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_${UPPER_CMAKE_BUILD_TYPE}}
+- -DLFLAGS:STRING=${CMAKE_EXE_LINKER_FLAGS} ${CMAKE_EXE_LINKER_FLAGS_${UPPER_CMAKE_BUILD_TYPE}}
+- -DOPTION_OMP:STRING=${OPTION_OMP}
+- -DWITH_MYFILE_MMAP:STRING=${WITH_MYFILE_MMAP}
+- -P ${CMAKE_CURRENT_SOURCE_DIR}/AboutThisBuild.cmake
+- COMMENT "Creating the about file"
+- )
+- find_file(HG_CMD hg)
+-
+ endif (WIN32)
+-
+- add_dependencies(AboutFile Debug Release MinSizeRel RelWithDebInfo)
+-
+- if (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+- message(FATAL_ERROR "hg command not found!")
+- else (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+- message(STATUS "hg command found: ${HG_CMD}")
+- endif (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+
+ endif (AUTOMATED_BUILD_SYSTEM)
+
+@@ -352,7 +324,6 @@
+
+ install (FILES AUTHORS.txt DESTINATION ${CREDITSDIR})
+ install (FILES LICENSE.txt DESTINATION ${LICENCEDIR})
+-install (FILES AboutThisBuild.txt DESTINATION ${CREDITSDIR})
+ install (FILES RELEASE_NOTES.txt DESTINATION ${CREDITSDIR} OPTIONAL)
+
+ add_subdirectory (rtexif)
+--- rawtherapee-4.0.9/rtgui/version.h
++++ rawtherapee-4.0.9/rtgui/version.h
+@@ -0,0 +1,11 @@
++// This file is automatically generated by the Makefile - DO NOT EDIT!
++// You can (should) also tell mercurial to ignore it.
++
++#ifndef _VERSION_
++#define _VERSION_
++
++#define VERSION "4.0.9"
++#define TAGDISTANCE 0
++#define CACHEFOLDERNAME "RawTherapee"
++
++#endif