summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-26 22:23:03 +0100
committerSam James <sam@gentoo.org>2022-07-26 22:38:25 +0100
commit28702e2a5310ec37e3957e761c8419237daf1ef1 (patch)
tree8c557aadb21baea735425b2d3507f182d83c26b2 /media-libs/ffmpegsource/ffmpegsource-2.40.ebuild
parentapp-shells/scsh: filter LTO (type mismatch) (diff)
downloadgentoo-28702e2a5310ec37e3957e761c8419237daf1ef1.tar.gz
gentoo-28702e2a5310ec37e3957e761c8419237daf1ef1.tar.bz2
gentoo-28702e2a5310ec37e3957e761c8419237daf1ef1.zip
media-libs/ffmpegsource: add 2.40
Closes: https://bugs.gentoo.org/851066 Closes: https://bugs.gentoo.org/834381 Closes: https://bugs.gentoo.org/859865 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/ffmpegsource/ffmpegsource-2.40.ebuild')
-rw-r--r--media-libs/ffmpegsource/ffmpegsource-2.40.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/ffmpegsource/ffmpegsource-2.40.ebuild b/media-libs/ffmpegsource/ffmpegsource-2.40.ebuild
new file mode 100644
index 000000000000..1ea646b97aa7
--- /dev/null
+++ b/media-libs/ffmpegsource/ffmpegsource-2.40.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QA_PKGCONFIG_VERSION=$(ver_cut 1-2)
+inherit autotools
+
+DESCRIPTION="A libav/ffmpeg based source library for easy frame accurate access"
+HOMEPAGE="https://github.com/FFMS/ffms2"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/FFMS/ffms2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/FFMS/ffms2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/ffms2-${PV}
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/4"
+
+RDEPEND="
+ >=media-video/ffmpeg-2.4:=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Cheesy hack from autogen.sh
+ mkdir src/config || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}