summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2022-03-14 10:42:02 +0100
committerSam James <sam@gentoo.org>2022-03-16 22:33:28 +0000
commit7045573738a58c8edd143fd3b3e6ee00ec6d4378 (patch)
tree1d4ea61ee58fd105da37291f8bc780a48b08b3b3 /media-libs/libvmaf/libvmaf-2.3.0.ebuild
parentdev-libs/imath: add header for f16c instructions on x86 (diff)
downloadgentoo-7045573738a58c8edd143fd3b3e6ee00ec6d4378.tar.gz
gentoo-7045573738a58c8edd143fd3b3e6ee00ec6d4378.tar.bz2
gentoo-7045573738a58c8edd143fd3b3e6ee00ec6d4378.zip
media-libs/libvmaf: new package
Needed to be able to use Netflix's quality of encoding scoring algorithm with ffmpeg Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libvmaf/libvmaf-2.3.0.ebuild')
-rw-r--r--media-libs/libvmaf/libvmaf-2.3.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/libvmaf/libvmaf-2.3.0.ebuild b/media-libs/libvmaf/libvmaf-2.3.0.ebuild
new file mode 100644
index 000000000000..33cbad2ec7f4
--- /dev/null
+++ b/media-libs/libvmaf/libvmaf-2.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="C libary for Netflix's Perceptual video quality assessment based on multi-method fusion."
+HOMEPAGE="https://github.com/Netflix/vmaf"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Netflix/vmaf.git"
+else
+ SRC_URI="
+ https://github.com/Netflix/vmaf/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2-with-patent"
+SLOT="0"
+
+BDEPEND="
+ dev-lang/nasm
+"
+
+RDEPEND="${BDEPEND}"
+
+S="${WORKDIR}/vmaf-${PV}"
+
+multilib_src_configure() {
+ EMESON_SOURCE="${S}/libvmaf"
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ insinto "/usr/share/vmaf"
+ doins -r "${S}/model"
+}