summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-03-15 23:36:31 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-03-15 23:38:58 +0000
commit88f49294f34b2ca2390e2beb58194a2d1243e37f (patch)
tree7cbbf9aff89fedff2a7dbd0bebe72f6a4114e384 /media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild
parentmedia-sound/easyeffects: add 6.2.4 (diff)
downloadgentoo-88f49294f34b2ca2390e2beb58194a2d1243e37f.tar.gz
gentoo-88f49294f34b2ca2390e2beb58194a2d1243e37f.tar.bz2
gentoo-88f49294f34b2ca2390e2beb58194a2d1243e37f.zip
media-libs/munt-mt32emu: Version bump to 2.6.1, EAPI 8
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild')
-rw-r--r--media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild b/media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild
new file mode 100644
index 000000000000..4a07225533b4
--- /dev/null
+++ b/media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P="libmt32emu_${PV//./_}"
+DESCRIPTION="Library for emulating the Roland MT-32, CM-32L, CM-64 and LAPC-I"
+HOMEPAGE="https://github.com/munt/munt"
+SRC_URI="https://github.com/munt/munt/archive/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/munt-${MY_P}/mt32emu"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.1-docs.patch
+)
+
+src_configure() {
+ local libdir=${EPREFIX}/usr/$(get_libdir)
+
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="${libdir}"
+ -Dlibmt32emu_PKGCONFIG_INSTALL_PREFIX="${libdir}"
+ )
+
+ cmake_src_configure
+}